Last Comment Bug 697720 - Add 'Clear private data' preference
: Add 'Clear private data' preference
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Android
: P1 normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
: 697711 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-27 08:06 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-01-09 12:07 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (10.65 KB, patch)
2011-10-27 08:06 PDT, Mark Finkle (:mfinkle) (use needinfo?)
blassey.bugs: review+
Details | Diff | Splinter Review
patch without ws changes (8.71 KB, patch)
2011-10-27 08:07 PDT, Mark Finkle (:mfinkle) (use needinfo?)
no flags Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-10-27 08:06:48 PDT
Created attachment 569975 [details] [diff] [review]
patch

We added support for clearing browsing history, but we can't clear passwords, cookies, site prefs and other Gecko-based data. This patch adds simple support for that.

It sends a message to Gecko, which then uses the sanitize.js code to do the dirty work. I removed Weave/Sync code from sanitize.

I also removed an unneeded "History" category string and untabbified the ConfirmPerference.java file.

I am also  attaching a no-whitespace change patch to make it easier to see the real changes.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-27 08:07:24 PDT
Created attachment 569976 [details] [diff] [review]
patch without ws changes

Without whitespace changes
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-27 08:22:17 PDT
*** Bug 697711 has been marked as a duplicate of this bug. ***
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-27 21:56:09 PDT
https://hg.mozilla.org/projects/birch/rev/cdb0a41ea68c
Comment 4 Aaron Train [:aaronmt] 2011-10-28 06:28:12 PDT
Verified Fixed

20111028040427
http://hg.mozilla.org/projects/birch/rev/cdb0a41ea68c

Note You need to log in before you can comment on or make changes to this bug.