Firefox freezes on File → Print... with a network print server

RESOLVED INVALID

Status

()

Core
Printing: Setup
--
major
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111028 Firefox/10.0a1
Build ID: 20111028031044

Steps to reproduce:

0. [Optional: remove the .mozilla directory (to have a really fresh profile and no add-ons.]
1. Start Firefox.
2. Go to any tab or open any page.
3. Select File → Print...


Actual results:

Firefox is completely frozen. The strace output shows a sequence of "poll" after the connection to the print server (I'll attach an excerpt of the strace output, truncated because the sequence of "poll" continues...). This is always reproducible on this machine.


Expected results:

Firefox shouldn't freeze.
(Reporter)

Comment 1

6 years ago
Created attachment 570254 [details]
Excerpt of strace output, starting with the connection to the print server
(Reporter)

Updated

6 years ago
Severity: normal → major
Bug 544791?
(Reporter)

Comment 3

6 years ago
I don't know. Bug 544791 is against Windows XP, while I'm under Linux. Does the OS matter?
(Reporter)

Comment 4

6 years ago
How do I know whether a printer is offline? FYI, "lpstat -a" says that all printers accept requests. So, I doubt this is bug 544791.
(Reporter)

Comment 5

6 years ago
Created attachment 574277 [details]
Print dialog with Iceweasel 5.0 on an old 32-bit distribution

I have an old 32-bit distribution via a chroot on the same machine, and I've tried it, and I get bug 544791 with the attached Print dialog. I don't know what are these printers at Guanaco. At least the print server don't know them.
(Reporter)

Comment 6

6 years ago
These printers at Guanaco are no longer visible (note that I remove the .mozilla directory each time) with Iceweasel 5.0. But the freeze still occurs with my standard distribution.
(Reporter)

Comment 7

6 years ago
Chromium has exactly the same problem! So, it could be due to some library, but which one?
(Reporter)

Comment 8

6 years ago
I've finally found that it is a bug in GTK 2:

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658389

So, I'm closing this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.