Last Comment Bug 698100 - Sync FrameState entries based on tracker
: Sync FrameState entries based on tracker
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 689284 687127
  Show dependency treegraph
 
Reported: 2011-10-28 14:25 PDT by Brian Hackett (:bhackett)
Modified: 2011-10-30 10:32 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.03 KB, patch)
2011-10-28 14:25 PDT, Brian Hackett (:bhackett)
dvander: review+
Details | Diff | Splinter Review

Description Brian Hackett (:bhackett) 2011-10-28 14:25:15 PDT
Created attachment 570360 [details] [diff] [review]
patch

As described in 685358 comment 4, the FrameState's current behavior of scanning all entries in OOL and inline sync paths can cost a lot of time.  This behavior was introduced with TI due to the need to keep the entire stack synced when making calls.  Given this requirement, it is faster on large scripts to scan tracked entries instead.  The attached patch reduces the sqlite compile time in bug 687127 from ~5250ms to ~4900ms.
Comment 1 Brian Hackett (:bhackett) 2011-10-29 18:17:07 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1b4d0987b18d
Comment 2 Ed Morley [:emorley] 2011-10-30 10:32:49 PDT
https://hg.mozilla.org/mozilla-central/rev/1b4d0987b18d

Note You need to log in before you can comment on or make changes to this bug.