Keyboard scrolling gets disabled.

RESOLVED DUPLICATE of bug 58250

Status

()

Core
Event Handling
--
minor
RESOLVED DUPLICATE of bug 58250
18 years ago
16 years ago

People

(Reporter: sami.makinen, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

Normally you can scroll a page using the arrow-keys, but following the steps
below make the arrow keys nonresponsive, and you have to scroll by mouse (or do
the workaround to reactivate).

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla and another program window or a second Mozilla window.
2. Go to any URL that has a page long enough to scroll. Don't do anything after
pressing enter, let the page load.
3. Click on (or ALT-TAB to) the other program/Mozilla window.
4. Swap back to the first window.
5. Keyboard scrolling doesn't work. Clicking on the page doesn't help.

Actual Results:  Keyboard scrolling stops working.

Expected Results:  Keyboard scrolling should work.

There are many ways to get this bug. Basically every time the browser gets a new
URL in any way, if you swap windows while it's loading the URL, when you swap
back keyboard scrolling doesn't work. The same bug has occurred for a long time
on various versions, and has been tested on Win2000 WkSt (SP1) and WinNT4 WkSt
(SP6a). Mozilla is the official release 0.8.

Workaround: Click on the URL-field=address bar, then click on the displayed
page. Keyboard scrolling reactivates, works every time.
Woraround2: Try to scroll the page while it's loading. Even if there's not
enough to scroll, this makes the keyboard scrolling work even if you swap windows.

Comment 1

18 years ago
over to event handling.  I think this is already covered by other reports.
Assignee: asa → joki
Component: Browser-General → Event Handling
QA Contact: doronr → gerardok

Comment 2

18 years ago
Sorry if spamming but isn't this related to bug #30841 ? Could the reporter tell
us if text fields are unusable too? If yes, this is another way to disable
keyboard (besides double right-clicking).

Updated

18 years ago
Blocks: 70812

Comment 3

18 years ago
This bug duplicates bug 58250.

Comment 4

17 years ago
Agreed duping.

*** This bug has been marked as a duplicate of 58250 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.