If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sun Java plugin creates ~/plugin130_01.trace on startup

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
P4
trivial
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Dave, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-21mdk i686; en-US; 0.8) Gecko/20010221
BuildID:    2001022109

I guess I would file this under minor nuisance:

Upon starting the browser and, I assume, while registering plugins, sun's VM
creates a file in the user's home directory called plugin130_01.trace. This file
contains the following:

Java(TM) Plug-in: Version 1.3.0_01
Using JRE version 1.3.0_01 Java HotSpot(TM) Client VM
User home directory = /home/vanbalen
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
q:   hide console
s:   dump system properties
t:   dump thread list
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

I, personally, believe that my browser's java plugin has no business placing
useless files in my home directory.

Reproducible: Always
Steps to Reproduce:
1.) Install java plugin, if not installed already (make sure to create the
symlink, as per bug 66840).
2.) Start browser and wait for java plugin to register.
3.) run ls ~/ from terminal
4.) If you're having the same problem as me, you'll se a plugin130_01.trace file
in your home directory.

Actual Results:  Without warning, an annoying and, to the best of my knowledge,
useless file is created in my home directory.

Expected Results:  The java plugin keeps its plugin trace to itself and doesn't
bother me with it.

Is there a reson for this?... if so, there must be a better way to do whatever
it is it's doing.

Comment 1

17 years ago
Reassign
Assignee: edburns → James.Melvin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Trace files should only appear on request.  The way to turn on 'trace'
is to set JAVA_PLUGIN_TRACE in the shell environment.  I will confirm
the tracefile appears without being requested and if so, file a bug in
bugtraq.  Do you by chance have this variable set?  My guess is no and
this is a bug.

(Reporter)

Comment 3

17 years ago
No, JAVA_PLUGIN_TRACE was not set... I didn't even know about it.

Upon setting it to 0, I still get the file but it now contains several lines
beginning with "Child:" after the content I posted above .I'm assuming this is a
trace. Setting the var to 1 has the same effect as setting it to zero. I guess
what it's set to doesn't matter.

Running unset JAVA_PLUGIN_TRACE after this returns to the original behavior
outlined in this bug's description (I get a file containing the usage info).
(Reporter)

Comment 4

17 years ago
Filed bug 4419663 in the http://java.sun.com bug database for this.

Comment 5

17 years ago
Making a guess at priority of this work.  Jim, forgive me if I guessed wrongly 
(it's really your role to assign priority to this bug as it's currently assigned 
to you).

Also, will you please accept this bug?
Priority: -- → P4

Comment 6

16 years ago
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac
(Reporter)

Comment 7

16 years ago
This bug has been closed on java.sun.com with "not a bug" as the resolution for
the following reason, and I quote:

"Plugin trace file is not dependent on the environment variable
JAVA_PLUGIN_TRACE, indeed trace file is created by default. We have plans to
give the user option of specifying filename, path and not to overwrite the same
file everytime in the merlin release. Also, the trace file will be named to
start with a '.', so that it is invisible with 'ls' command."

I'm assuming that this means it'll be fixed in the next version of the jre. If
you have any input as to what should be done with the file, please add it to the
bug filed with Sun.

Setting to "Later" so it can be marked "fixed" when the file is no longer visible.

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → LATER

Comment 8

15 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: James.Melvin → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen
LATER is deprecated per bug 35839. Has the JRE been updated? Does this bug still
exist?
Status: RESOLVED → REOPENED
Resolution: LATER → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.