Last Comment Bug 698248 - Remove FORCE_USE_PIC
: Remove FORCE_USE_PIC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Gregory Szorc [:gps]
:
: Gregory Szorc [:gps]
Mentors:
Depends on: 648911
Blocks: 701683 892898
  Show dependency treegraph
 
Reported: 2011-10-29 23:31 PDT by Gregory Szorc [:gps]
Modified: 2013-07-12 02:04 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove FORCE_USE_PIC, v1 (32.50 KB, patch)
2011-10-31 11:30 PDT, Gregory Szorc [:gps]
khuey: review+
Details | Diff | Splinter Review
Remove FORCE_USE_PIC, v1 - reviewed (32.51 KB, patch)
2011-11-01 10:58 PDT, Gregory Szorc [:gps]
gps: review+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2011-10-29 23:31:41 PDT
Unless MXR is letting me down, it appears FORCE_USE_PIC=1 is defined 58 times in 57 files but it isn't being used anywhere. Unless there is a need for it, it should probably be removed from all the Makefiles.
Comment 1 Mark Banner (:standard8, afk until Dec) 2011-10-31 01:45:25 PDT
Looks like it was bug 648911 that removed the use of this http://hg.mozilla.org/mozilla-central/rev/8e846d7f21ea
Comment 2 Gregory Szorc [:gps] 2011-10-31 11:30:10 PDT
Created attachment 570769 [details] [diff] [review]
Remove FORCE_USE_PIC, v1

Here is a straightforward patch that removes FORCE_USE_PIC and associated comments from all the Makefile.in's.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-11-01 09:28:48 PDT
Comment on attachment 570769 [details] [diff] [review]
Remove FORCE_USE_PIC, v1

I didn't actually verify that these are all of the occurrences in m-c, but this looks good.
Comment 4 Gregory Szorc [:gps] 2011-11-01 10:58:51 PDT
Created attachment 571061 [details] [diff] [review]
Remove FORCE_USE_PIC, v1 - reviewed

Same patch as before. Updated subject line to reflect review. Need checkin.
Comment 5 Gregory Szorc [:gps] 2011-11-01 15:47:33 PDT
I got level 3, so I pushed this to build-system: http://hg.mozilla.org/projects/build-system/rev/e9e6741defd4
Comment 6 Gregory Szorc [:gps] 2011-11-10 15:24:32 PST
Merged to m-c: https://hg.mozilla.org/mozilla-central/rev/e9e6741defd4

Note You need to log in before you can comment on or make changes to this bug.