Closed Bug 698286 Opened 8 years ago Closed 8 years ago

Bookmark Manager and sidebar completely empty

Categories

(SeaMonkey :: Bookmarks & History, defect, blocker)

defect
Not set
blocker

Tracking

(seamonkey2.7 fixed)

RESOLVED FIXED
seamonkey2.7
Tracking Status
seamonkey2.7 --- fixed

People

(Reporter: InvisibleSmiley, Assigned: neil)

References

Details

Attachments

(1 file)

Error: PlacesUtils.asContainer(this._places.selectedNode) is null
Source File: chrome://communicator/content/bookmarks/bookmarksManager.js
Line: 65

The above is probably just a symptom; you get no error when just opening the sidebar and activate the Bookmarks panel [the errors that appear when typing there have probably been fixed already for the next nightlies through changeset 0e560a2d28a3]. The Personal Toolbar seems to be unaffected.

Very likely suspects (landed 2011-10-27) affecting Toolkit/Places:
* Bug 696159 - Remove some deprecated Places code
http://hg.mozilla.org/mozilla-central/rev/1ed8be9fed394427989006195532d11c524f5d0d
* Bug 692120 - The star button doesn't need to observe bookmarks changes till bookmarks service is alive.
http://hg.mozilla.org/mozilla-central/rev/1d659cf02d6b2db07a8ddfc7d82d122a28970873

We should probably port both ASAP. Luckily they don't affect l10n so we can fix it on Aurora if we don't make it until the next uplift.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #570561 - Flags: review?(iann_bugzilla)
Attachment #570561 - Flags: review?(iann_bugzilla) → review+
Duplicate of this bug: 698717
Comment on attachment 570561 [details] [diff] [review]
Stop using deprecated methods [Checkin: comment 4]

http://hg.mozilla.org/comm-central/rev/391c1e8fc7c3
Attachment #570561 - Attachment description: Stop using deprecated methods → Stop using deprecated methods [Checkin: comment 4]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.7
You need to log in before you can comment on or make changes to this bug.