Last Comment Bug 698303 - [Meta] Mark DOM method arguments optional per the DOM4 spec
: [Meta] Mark DOM method arguments optional per the DOM4 spec
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Matthew Schranz [:mjschranz]
:
Mentors:
Depends on: 698381 698384 698385
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-30 14:25 PDT by Jonas Sicking (:sicking) No longer reading bugmail consistently
Modified: 2012-02-24 19:22 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-10-30 14:25:10 PDT
Arguments which are optional in DOM4 but not in our implementation:

Node.cloneNode(optional boolean deep);  (Note, defaults to true)
Document.createNodeIterator(Node root, optional unsigned long whatToShow,
                            optional NodeFilter? filter);
Document.createTreeWalker(Node root, optional unsigned long whatToShow,
                          optional NodeFilter? filter);
Comment 1 Olli Pettay [:smaug] 2011-10-30 18:13:43 PDT
The latter two methods used to take also bool aEntityReferenceExpansion as parameter.
We could perhaps make also that optional, or just leave it out.
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-10-30 18:22:31 PDT
I think we should just leave it out and make .expandEntityReferences return false.

(We should even make .expandEntityReferences warn if used and then remove it a release later. But that might be a separate bug)
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-10-30 18:25:49 PDT
Actually, we might even be able to remove .expandEntityReferences right away given that it's a property. So we won't throw if people use it, just return a falsy value (undefined).
Comment 4 Olli Pettay [:smaug] 2011-10-31 04:49:39 PDT
Although the changes will be small, I'd prefer making them in separate patches/bugs so that if
some of them isn't web compatible, it can be easily backed out.
Comment 5 Matthew Schranz [:mjschranz] 2012-01-06 19:13:15 PST
I figure that since I'm working on 698384 and 698385 I might as well go for this one as well, unless someone objects.
Comment 6 Matthew Schranz [:mjschranz] 2012-02-24 19:22:16 PST
All three of the "sub tickets" 698381 698384 and 698385 are now resolved and have landed.

Note You need to log in before you can comment on or make changes to this bug.