Inline images silently stripped without trace when force-sending HTML mail as plaintext mail (Options > Format > Plain Text only)

RESOLVED DUPLICATE of bug 180997

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 180997
7 years ago
6 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Bug 698262 claims that the image was stripped entirely, without trace. Investigate. We should at least insert a hint that there was something, even if we cannot send the image.
Confirming.

STR

1 Create new HTML message
2 insert inline image (check "attach this img to the message")
3 Change Options > Format to "Plain Text only" to force plaintext
4 Send

Actual result

3 inline image still shown in editor; no warning of any sort; no conversion to real attachment; all formatting still possible (bold, italics, etc) using Keyboard Shortcuts - aren't we in plaintext?
(the truth is, it's just html editor without toolbar and some missing menus)

4 inline image is silently stripped when sending - no trace, no warning, just gone. Bad. At least bold, italics & friends are converted to their plaintext equivalents, *bold*, /italics/ etc.

Expected

3 Do something about the inline image because plaintext msg can't have inline img (some possiblities; might be combined)
- warn and instruct user what to do 
- autoconvert inline images to real attachments
- remove inline img (?) but ensure there's no dataloss

4 At least now when sending, we *really* need to do something similar to 3 above...:
warn, autoconvert, or offer to send as html etc...

Related bugs are pretty messy so there might be dupes.
Summary: Image stripped when force-sending as plaintext mail? → Inline images stripped when force-sending HTML mail as plaintext mail
Summary: Inline images stripped when force-sending HTML mail as plaintext mail → Inline images silently stripped without trace when force-sending HTML mail as plaintext mail (Options > Format > Plain Text only)
This might be a dependent of bug 509316 or bug 470062.
Or, dependent of main problem, Bug 216132.
It would not be TB if all the bugs were not known from time immemorial.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 180997
You need to log in before you can comment on or make changes to this bug.