Last Comment Bug 698410 - Pass JSObject to nsIScriptContext::InitClasses
: Pass JSObject to nsIScriptContext::InitClasses
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks: 695753
  Show dependency treegraph
 
Reported: 2011-10-31 06:22 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-11-26 07:37 PST (History)
1 user (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.49 KB, patch)
2011-10-31 06:22 PDT, :Ms2ger (⌚ UTC+1/+2)
jmaher: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-10-31 06:22:47 PDT
Created attachment 570681 [details] [diff] [review]
Patch v1

The callers already have JSObjects.
Comment 1 Joel Maher ( :jmaher) 2011-10-31 06:32:48 PDT
Comment on attachment 570681 [details] [diff] [review]
Patch v1

Review of attachment 570681 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming all who call InitClasses are passing in a JSObject (which seems like the case since we were casting it already and you said so in your comment), r=me.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-11-26 07:37:42 PST
https://hg.mozilla.org/mozilla-central/rev/cc704ca32976

Note You need to log in before you can comment on or make changes to this bug.