Last Comment Bug 698534 - Build fails when smil is disabled
: Build fails when smil is disabled
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: 693145
  Show dependency treegraph
 
Reported: 2011-10-31 12:07 PDT by Mounir Lamouri (:mounir)
Modified: 2011-11-02 06:34 PDT (History)
3 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (723 bytes, patch)
2011-10-31 12:07 PDT, Mounir Lamouri (:mounir)
dholbert: review+
Details | Diff | Review
Patch v2 (2.76 KB, patch)
2011-10-31 12:53 PDT, Mounir Lamouri (:mounir)
dholbert: review+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2011-10-31 12:07:14 PDT
Created attachment 570784 [details] [diff] [review]
Patch
Comment 1 Mounir Lamouri (:mounir) 2011-10-31 12:53:19 PDT
Created attachment 570802 [details] [diff] [review]
Patch v2

Looks like other things were broken.
Comment 2 Robert Longson 2011-10-31 14:10:22 PDT
Wouldn't we be better just removing the MOZ_SMIL defines and having SMIL in the build always.
Comment 3 Mounir Lamouri (:mounir) 2011-10-31 15:56:52 PDT
(In reply to Robert Longson from comment #2)
> Wouldn't we be better just removing the MOZ_SMIL defines and having SMIL in
> the build always.

Most of my dev builds have --disable-smil and I didn't get that many issues with SMIL. Actually, it's been a long time since I got any build issues because of my disabled options.

However, if the reasons why this option exist doesn't apply anymore, I would be fine with removing it. Though, can we fix that bug first? :)
Comment 4 Daniel Holbert [:dholbert] 2011-10-31 16:13:20 PDT
Comment on attachment 570802 [details] [diff] [review]
Patch v2

Looks good.  Sorry for not having caught this in review on bug 693145.

I'll file a separate bug on removing MOZ_SMIL #ifdefs.
Comment 5 Daniel Holbert [:dholbert] 2011-10-31 16:21:35 PDT
(Filed bug 698630 on removing the --disable-smil option)
Comment 6 Daniel Holbert [:dholbert] 2011-11-01 13:30:25 PDT
volkmar landed this as:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b2c58afeead0

Removing [inbound] per https://wiki.mozilla.org/Tree_Rules/Inbound
Comment 7 Ed Morley [:emorley] 2011-11-02 06:34:28 PDT
https://hg.mozilla.org/mozilla-central/rev/b2c58afeead0

Note You need to log in before you can comment on or make changes to this bug.