Closed Bug 698545 Opened 8 years ago Closed 8 years ago

services/makefiles.sh failure during config

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: joey, Unassigned)

Details

add "set -oe" in services/makefile.sh and a configure problem will become visible.


creating media/libsydneyaudio/src/Makefile
creating services/Makefile
creating services/crypto/Makefile
creating services/crypto/tests/Makefile
creating services/sync/Makefile
creating services/sync/locales/Makefile
creating services/sync/tests/Makefile
*** Fix above errors and then restart with               "gmake -f client.mk build"
gmake: *** [configure] Error 1
I tried this myself (except for mingw32 I have to use set -o errexit), and by a process of elimination using echos scattered throughout, it appears the problem is not in services/makefile.sh, it's a couple of lines further on in configure (after allmakefiles.sh has been called):
{
mv -f config/autoconf.mk config/autoconf.mk.orig 2> /dev/null
}

ie: would need to use the workaround in http://www.davidpashley.com/articles/writing-robust-shell-scripts.html, since at the moment bash is correctly exiting as the return value is false.

However I suspect it's opening a can of worms (who knows what else would need to be rewritten throughout configure + elsewhere), so for now I decided to turn off |set -o errexit| at the end of allmakefiles.sh (see bug 703930).
Per the bug summary, this is invalid, since there was no error in services/makefiles.sh

However, a good possible breakout bug would be to investigate using |set -o errexit| in configure after making the workarounds described in comment 1, if it was deemed desirable. Suspect it may be a non-trivial amount of work though.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.