Last Comment Bug 698590 - images with fractional opacity are positioned outside container when page is zoomed
: images with fractional opacity are positioned outside container when page is ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: mozilla10
Assigned To: Matt Woodrow (:mattwoodrow)
:
:
Mentors:
https://www.google.com/voice
: 698711 700374 (view as bug list)
Depends on: 745549
Blocks: 695275
  Show dependency treegraph
 
Reported: 2011-10-31 14:31 PDT by Matthew N. [:MattN] (In Taipei until Sep. 23)
Modified: 2012-04-15 19:45 PDT (History)
10 users (show)
matt.woodrow: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Actual Result: Screenshot of toolbar with images positioned outside container (15.69 KB, image/png)
2011-10-31 14:31 PDT, Matthew N. [:MattN] (In Taipei until Sep. 23)
no flags Details
testcase: <img> with opacity position incorrect after zoom (454 bytes, text/html)
2011-10-31 14:58 PDT, Matthew N. [:MattN] (In Taipei until Sep. 23)
no flags Details
Make ConfigureLayer use DevPixels instead of AppPixels. (1.08 KB, patch)
2011-11-02 13:53 PDT, Matt Woodrow (:mattwoodrow)
roc: review+
Details | Diff | Splinter Review
Add reftest for zoomed ImageLayer (1.15 KB, patch)
2011-11-28 20:55 PST, Matt Woodrow (:mattwoodrow)
roc: review+
Details | Diff | Splinter Review

Description Matthew N. [:MattN] (In Taipei until Sep. 23) 2011-10-31 14:31:38 PDT
Created attachment 570847 [details]
Actual Result: Screenshot of toolbar with images positioned outside container

Since the nightly build on 2011-10-27, the toolbar images on Google Voice are positioned outside of their containing <div> when the page is zoomed in.  See screenshot of the problem.

STR:
1) Load https://www.google.com/voice and login/create an account (sorry, U.S only)
2) Zoom in on the page

Actual result:
some button images are positioned outside the container <div>

Expected result:
button image zooms but stays within the <div>

Last good nightly: 10.0a1 (2011-10-26)
Built from http://hg.mozilla.org/mozilla-central/rev/cc66accc8181

First bad nightly:
Built from http://hg.mozilla.org/mozilla-central/rev/4bb7c983d589

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc66accc8181&tochange=4bb7c983d589
Comment 1 Matthew N. [:MattN] (In Taipei until Sep. 23) 2011-10-31 14:58:28 PDT
Created attachment 570858 [details]
testcase: <img> with opacity position incorrect after zoom

This seems to be a problem with positioning the img if there is opacity specified on the <img> and the page is zoomed. Not sure if it's a gfx or layout bug.
Comment 2 Alice0775 White 2011-11-01 11:17:04 PDT
Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/98013fe19dcb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025195747
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d7f3bfc7cd46
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025203245
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98013fe19dcb&tochange=d7f3bfc7cd46
Triggered by:
8b89d7037306	Matt Woodrow — Bug 695275 - Fix conversion of ThebesLayers to ImageLayers. r=roc
Comment 3 Alice0775 White 2011-11-01 11:47:30 PDT
*** Bug 698711 has been marked as a duplicate of this bug. ***
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-01 20:36:24 PDT
devpixels/CSSpixels confusion presumably
Comment 5 Matt Woodrow (:mattwoodrow) 2011-11-02 13:53:23 PDT
Created attachment 571447 [details] [diff] [review]
Make ConfigureLayer use DevPixels instead of AppPixels.
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-02 14:14:02 PDT
Comment on attachment 571447 [details] [diff] [review]
Make ConfigureLayer use DevPixels instead of AppPixels.

Review of attachment 571447 [details] [diff] [review]:
-----------------------------------------------------------------

Reftest?
Comment 7 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-11-07 12:27:47 PST
*** Bug 700374 has been marked as a duplicate of this bug. ***
Comment 8 Matt Woodrow (:mattwoodrow) 2011-11-07 19:59:06 PST
Landed this as https://hg.mozilla.org/integration/mozilla-inbound/rev/95efc21bf5af to try make the next aurora merge.

Will get a reftest added asap, please leave bug open.
Comment 9 Ed Morley [:emorley] 2011-11-08 07:08:40 PST
https://hg.mozilla.org/mozilla-central/rev/95efc21bf5af

(Leaving open for retest, per comment 8)
Comment 10 Bryan Price 2011-11-08 09:50:28 PST
Today's nightly is actually worse for Gvoice/Greader (especially Greader, it's broke even without any zoom...)
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-08 13:33:39 PST
Does that build have this fix?
Comment 12 Michał 2011-11-08 13:49:34 PST
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #11)
> Does that build have this fix?
I think it will be in next Nightly (09-11-2011), beacause now I can't see any difference.
Comment 13 Bryan Price 2011-11-08 14:35:21 PST
Google fixed the issue I was having(as long as you don't zoom).  Weird.
Comment 14 Drew Noel 2011-11-09 06:26:27 PST
I can confirm that it is fixed in my Nightly.

Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111109 Firefox/11.0a1 ID:20111109031111
Comment 15 Alex Keybl [:akeybl] 2011-11-28 13:50:00 PST
Doesn't occur on FF10 for me, even with zooming.
Comment 16 Matt Woodrow (:mattwoodrow) 2011-11-28 20:55:34 PST
Created attachment 577477 [details] [diff] [review]
Add reftest for zoomed ImageLayer
Comment 17 Matt Woodrow (:mattwoodrow) 2011-12-04 14:55:12 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/6d36479d1250
Comment 18 Matt Brubeck (:mbrubeck) 2011-12-05 10:29:59 PST
Reftest landed in mozilla11:
https://hg.mozilla.org/mozilla-central/rev/6d36479d1250

Note You need to log in before you can comment on or make changes to this bug.