crash @ [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

Firefox 9
ARM
Android
crash

Details

(Whiteboard: str-wanted, [mobile-crash][native-crash:P2], crash signature)

This bug was filed from the Socorro interface and is 
report bp-f104d1aa-df52-45c0-b3cf-1e56e2111030 .
============================================================= 

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:66
1 	libc.so 	libc.so@0x1a079 	
2 	libdvm.so 	libdvm.so@0x87ba1 	
3 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus 	other-licenses/android/APKOpen.cpp:242
4 		@0x4d46f006 	
5 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	other-licenses/android/APKOpen.cpp:243
6 	libdvm.so 	libdvm.so@0x11e76 	
7 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1ec9c2 	
8 	dalvik-heap (deleted) 	dalvik-heap @0x616b9e 	
9 	libdvm.so 	libdvm.so@0x43721 	
10 	data@app@org.mozilla.fennec_aurora-1.apk@classes.dex 	data@app@org.mozilla.fennec_aurora-1.apk@classes.dex@0x14090 	
11 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus 	other-licenses/android/APKOpen.cpp:242
12 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1ec9c2 	
13 	libdvm.so 	libdvm.so@0x436db 	
14 	dalvik-heap (deleted) 	dalvik-heap @0x616b9e 	
15 	libdvm.so 	libdvm.so@0x48e9f 	
16 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1ec9c2 	
17 	data@app@org.mozilla.fennec_aurora-1.apk@classes.dex 	data@app@org.mozilla.fennec_aurora-1.apk@classes.dex@0x9610 	
18 	dalvik-heap (deleted) 	dalvik-heap @0x616b9e 	
19 	libdvm.so 	libdvm.so@0x1203e 	
20 	libdvm.so 	libdvm.so@0x17076 	
21 	libdvm.so 	libdvm.so@0x9f372 	
22 	libdvm.so 	libdvm.so@0x1c126 	
23 	libdvm.so 	libdvm.so@0x1c096 	
24 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0xa520e 	
25 	libdvm.so 	libdvm.so@0x1b01e 	
26 	dalvik-heap (deleted) 	dalvik-heap @0x3d3c6 	
27 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x1843aa 	
28 	dalvik-heap (deleted) 	dalvik-heap @0x63de76 	
29 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1e6fde 	
30 	dalvik-heap (deleted) 	dalvik-heap @0x39fff6e 	
31 	libdvm.so 	libdvm.so@0xa3b16 	
32 	dalvik-heap (deleted) 	dalvik-heap @0x5076fe 	
33 	libdvm.so 	libdvm.so@0x16d56 	
34 	libdvm.so 	libdvm.so@0x16dce 	
35 	libdvm.so 	libdvm.so@0x16c76 	
36 	libdvm.so 	libdvm.so@0x16c9e 	
37 	libdvm.so 	libdvm.so@0x16cce 	
38 	libdvm.so 	libdvm.so@0x16cf2 	
39 	libdvm.so 	libdvm.so@0x796af 	
40 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x1697da 	
41 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x1697da 	
42 	system@framework@core.jar@classes.dex 	system@framework@core.jar@classes.dex@0x16998e 	


https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-10-31%2012%3A00%3A00&signature=mozalloc_abort%20|%20Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus&version=Fennec%3A9.0a2

Note: Still trying to reproduce this crash.  Guessing it has to do with the change in network link status based on the crash.

Updated

7 years ago
Whiteboard: str-wanted, [mobile-crash]
https://crash-stats.mozilla.com/report/index/c9f9f674-9aac-4f85-b9e2-8f9c22111107 shows example of [@ mozalloc_abort | __swrite ]
Crash Signature: [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] → [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] [@ mozalloc_abort | __swrite ]
Crash Signature: [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] [@ mozalloc_abort | __swrite ] → [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] [@ mozalloc_abort | __swrite ] [@ mozalloc_abort | dexDataMapAlloc ]
Occurs on Marcia's device.  I suspect it's due to change in status for 3G to 4G or vice versa.  She doesn't use wireless network connections.
Whiteboard: str-wanted, [mobile-crash] → str-wanted, [mobile-crash][native-crash]
Setting as P2: volume is high on the crash list, no str.  str-wanted.
Whiteboard: str-wanted, [mobile-crash][native-crash] → str-wanted, [mobile-crash][native-crash:P2]
Duplicate of this bug: 708306

Updated

7 years ago
Keywords: topcrash

Comment 5

7 years ago
As __swrite has been added to the skiplist, I change the crash signature.
Crash Signature: [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] [@ mozalloc_abort | __swrite ] [@ mozalloc_abort | dexDataMapAlloc ] → [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus ] [@ mozalloc_abort | __swrite | Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus] [@ mozalloc_abort | dexDataMapAlloc ]

Comment 6

7 years ago
The mozalloc_abort | dexDataMapAlloc crash is only #12 in 11.0a2 and #22 in 12.0a1.
The other crash signatures no longer occur.
Keywords: topcrash
You need to log in before you can comment on or make changes to this bug.