Closed Bug 698638 Opened 10 years ago Closed 10 years ago

crash [@ TOutputGLSLBase::visitSymbol]

Categories

(Core :: Canvas: WebGL, defect)

9 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 694831

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: crash, Whiteboard: [mobile-crash])

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libmozutils.so 	arena_dalloc 	memory/jemalloc/jemalloc.c:4306
1 	libmozutils.so 	__wrap_free 	memory/jemalloc/jemalloc.c:6260
2 	libmozalloc.so 	moz_free 	memory/mozalloc/mozalloc.cpp:97
3 	libxul.so 	std::__node_alloc::deallocate 	mozalloc.h:253
4 	libxul.so 	std::priv::_String_base<char, std::allocator<char> >::_M_deallocate_block 	_alloc.h:323
5 	libxul.so 	std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_append 	_string.c:205
6 	libxul.so 	TInfoSinkBase::operator<< 	_string.h:530
7 	libxul.so 	TOutputGLSLBase::visitSymbol 	gfx/angle/src/compiler/OutputGLSLBase.cpp:199
8 	libxul.so 	TIntermSymbol::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:28
9 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:161
10 	libxul.so 	TIntermBinary::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:89
11 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:161
12 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/OutputGLSLBase.cpp:452
13 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
14 	libxul.so 	TOutputGLSLBase::visitCodeBlock 	gfx/angle/src/compiler/OutputGLSLBase.cpp:704
15 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/OutputGLSLBase.cpp:500
16 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
17 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/OutputGLSLBase.cpp:452
18 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
19 	libxul.so 	TranslatorESSL::translate 	gfx/angle/src/compiler/TranslatorESSL.cpp:27
20 	libxul.so 	TCompiler::compile 	gfx/angle/src/compiler/Compiler.cpp:181
21 	libxul.so 	ShCompile 	gfx/angle/src/compiler/ShaderLang.cpp:169
22 	libxul.so 	mozilla::WebGLContext::CompileShader 	content/canvas/src/WebGLContextGL.cpp:4063
23 	libxul.so 	nsIDOMWebGLRenderingContext_CompileShader 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:29865
24 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:296
25 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:614
26 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:678
27 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5030
28 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1929
29 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:211
30 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:736
31 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:790
32 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:160
33 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:344
34 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:672
35 	libxul.so 	DocumentViewerImpl::LoadComplete 	layout/base/nsDocumentViewer.cpp:1067
36 	libxul.so 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6154
37 	libxul.so 	nsDocShell::OnStateChange 	docshell/base/nsDocShell.cpp:5990
38 	libxul.so 	nsDocLoader::DoFireOnStateChange 	uriloader/base/nsDocLoader.cpp:1383
39 	libxul.so 	nsDocLoader::doStopDocumentLoad 	uriloader/base/nsDocLoader.cpp:963
40 	libxul.so 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.cpp:852
41 	libxul.so 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:736
42 	libxul.so 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:734
43 	libxul.so 	nsDocument::DoUnblockOnload 	content/base/src/nsDocument.cpp:7230
44 	libxul.so 	nsDocument::UnblockOnload 	content/base/src/nsDocument.cpp:7172
45 	libxul.so 	nsLoadBlockingPLDOMEvent::~nsLoadBlockingPLDOMEvent 	content/events/src/nsPLDOMEvent.cpp:100
46 	libxul.so 	nsLoadBlockingPLDOMEvent::~nsLoadBlockingPLDOMEvent 	content/events/src/nsPLDOMEvent.cpp:102
47 	libxul.so 	nsRunnable::Release 	obj-firefox/xpcom/build/nsThreadUtils.cpp:55
48 	libxul.so 	nsCOMPtr_base::~nsCOMPtr_base 	obj-firefox/xpcom/build/nsCOMPtr.cpp:81
49 	libxul.so 	nsThread::ProcessNextEvent 	nsCOMPtr.h:515
50 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
51 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
52 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:229
53 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
54 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
55 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
56 	libxul.so 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp:677
57 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:215
58 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
59 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
60 	libxul.so 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:516
61 	libmozutils.so 	ChildProcessInit 	other-licenses/android/APKOpen.cpp:782
62 	plugin-container 	main 	ipc/app/MozillaRuntimeMainAndroid.cpp:68
63 	libc.so 	__libc_init 	
64 		@0xb0004591
Does this only show up on mobile?
Component: Graphics → Canvas: WebGL
QA Contact: thebes → canvas.webgl
This seems to be specific to the GLSL ES backend:
http://code.google.com/p/angleproject/issues/detail?id=230
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694831
You need to log in before you can comment on or make changes to this bug.