Crash in libc-2.13.so@0x10.... on Ubuntu while playing VLC

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, topcrash})

8 Branch
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox8 affected, firefox9 unaffected, firefox10 unaffected, firefox11 unaffected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-19eef589-75e7-447c-a6a4-2b56b2111031 .
============================================================= 

This signature shows up in the explosive report. Looks as if an Ubuntu update may be causing some problems in the audio and video area judging from the comments. https://crash-stats.mozilla.com/report/list?signature=libc-2.13.so%400x10fc79

https://crash-stats.mozilla.com/report/index/1b42a5a9-212f-40aa-a94d-572fa2111030

Frame 	Module 	Signature [Expand] 	Source
0 	libc-2.13.so 	libc-2.13.so@0x10fc79 	
1 	libc-2.13.so 	libc-2.13.so@0x177ff3 	
2 	libc-2.13.so 	libc-2.13.so@0x61e74 	
3 	libc-2.13.so 	libc-2.13.so@0x6be7c 	
4 	libc-2.13.so 	libc-2.13.so@0xc1293 	
5 	libc-2.13.so 	libc-2.13.so@0x6acba 	
6 	libc-2.13.so 	libc-2.13.so@0x177ff3 	
7 	libc-2.13.so 	libc-2.13.so@0x6bed8 	
8 	libc-2.13.so 	libc-2.13.so@0x6bcef 	
9 	libc-2.13.so 	libc-2.13.so@0x177ff3 	
10 	libc-2.13.so 	libc-2.13.so@0x622c1 	
11 	liblua5.1.so.0.0.0 	liblua5.1.so.0.0.0@0x2cff3 	
12 	liblua5.1.so.0.0.0 	liblua5.1.so.0.0.0@0x16c43 	
13 	liblua5.1.so.0.0.0 	liblua5.1.so.0.0.0@0x22707 	
14 	libxul.so 	ReplaceRegExpCallback 	jsstr.cpp:1862
15 		@0xb17fee53 	
16 		@0x1

Comment 1

6 years ago
The libc-2.13.so@0x10fc79 crash signature occurs on Ubuntu 3.0 and above.
The libc-2.13.so@0x10d714 crash signature occurs on Ubuntu 2.6.38.

They are correlated to the VLC plugin:
* libc-2.13.so@0x10fc79|SIGSEGV (94 crashes)
    100% (94/94) vs.  20% (140/715) libvlcplugin.so
        100% (94/94) vs.  13% (94/715) 82EB688387745AC87EFF6F44C182346F0
* libc-2.13.so@0x10d714|SIGSEGV (20 crashes)
    100% (20/20) vs.  20% (140/715) libvlcplugin.so
          5% (1/20) vs.   0% (1/715) 033A81748D63A636C65F69B3C5F0B9AC0
         10% (2/20) vs.   0% (2/715) 0B3299744D53BE3626E7F0F22DF7B1AC0
         85% (17/20) vs.   2% (17/715) D5C1CDAF8F0DCC4DD16CC366D2E8C9080
Crash Signature: [@ libc-2.13.so@0x10fc79 ] → [@ libc-2.13.so@0x10fc79 ] [@ libc-2.13.so@0x10d714 ]
Component: General → VLC (VideoLAN)
Product: Firefox → Plugins
QA Contact: general → videolan-vlc
Summary: crash libc → Crash in libc-2.13.so@0x10.... on Ubuntu while playing VLC
Version: 8 Branch → 1.x

Comment 2

6 years ago
It's #1 top crasher on Linux in 8.0 with 47% of all crashes.

Can we have contact at Videolan?

Comment 3

6 years ago
This was fixed in #699734, and definitely works in Nightly.

Comment 4

6 years ago
(In reply to Asher Baker from comment #3)
> This was fixed in #699734, and definitely works in Nightly.
Are you sure of the bug that is not related to plugins?
status-firefox10: --- → affected
status-firefox9: --- → affected
tracking-firefox10: --- → ?
tracking-firefox9: --- → ?

Updated

6 years ago
status-firefox10: affected → ---
status-firefox9: affected → ---
tracking-firefox10: ? → ---
tracking-firefox9: ? → ---
Keywords: topcrash
If this is the same bug, current beta should work, actually, because the jemalloc-standalone-linkage-version-script file is not used anymore.
Verifying the tarballs, I can see the _IO_stdin_used symbol exported on 9.0b6 builds and not on 8.0.1 x86-64 builds. Note that 8.0.1 i686 builds have the symbol exported, so I supposed the problem is limited to x86-64. (if that's the same problem).

Comment 6

6 years ago
Those crashes happen only on x86 in 8.0 and below.
Then this could be a similar issue, but with a different symbol.

Comment 8

6 years ago
Have you tried using Nightly? I had the exact same issue on x86 with the VLC plugin until I switched to a nightly build that had the above mentioned fix.

Comment 9

6 years ago
Asher, are you able to reproduce it on 9.0 Beta?

Comment 10

6 years ago
9.0 Beta appears to work fine.

Updated

6 years ago
status-firefox10: --- → unaffected
status-firefox11: --- → unaffected
status-firefox8: --- → affected
status-firefox9: --- → unaffected

Updated

6 years ago
Component: VLC (VideoLAN) → General
Product: Plugins → Firefox
QA Contact: videolan-vlc → general
Version: 1.x → 8 Branch

Comment 11

6 years ago
There have been no crashes in versions above 8.0 for the last four weeks.
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.