Upgrade WebGL conformance test suite to r15981

RESOLVED FIXED in mozilla10

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: bjacob, Assigned: bjacob)

Tracking

unspecified
mozilla10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

https://tbpl.mozilla.org/?tree=Try&rev=77d835cc986a
(Assignee)

Comment 1

6 years ago
https://tbpl.mozilla.org/?tree=Try&rev=d46689b01860
(Assignee)

Comment 2

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/be8056caccb4

The only nontrivial change is that the garbageCollect call is now done on all platforms, instead of only linux. Clear from the purples on https://tbpl.mozilla.org/?tree=Try&rev=d46689b01860 . Added this comment:

    // Calling garbageCollect before each test page fixes intermittent failures with
    // out-of-memory errors, often failing to create a WebGL context.
    // The explanation is that the JS engine keeps unreferenced WebGL contexts around
    // for too long before GCing (bug 617453), so that during this mochitest dozens of unreferenced
    // WebGL contexts can accumulate at a given time.
    SpecialPowers.DOMWindowUtils.garbageCollect();

Comment 3

6 years ago
M1 orange on this push:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=be8056caccb4

Presume it just needs the test annotation changing to reflect the test is now passing.
Backed out on inbound for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c55634fffb6
(Assignee)

Comment 5

6 years ago
indeed, that test had to be removed from failing_tests_*.txt.

http://hg.mozilla.org/integration/mozilla-inbound/rev/866c4e972918
(Assignee)

Comment 6

6 years ago
Followup removing one test from the windows failures list:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cedae68ef0e2
https://hg.mozilla.org/mozilla-central/rev/866c4e972918
https://hg.mozilla.org/mozilla-central/rev/cedae68ef0e2
Assignee: nobody → bjacob
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
(Assignee)

Updated

5 years ago
Duplicate of this bug: 595352
You need to log in before you can comment on or make changes to this bug.