Last Comment Bug 698967 - test_transitions_per_property says "interpolation of lengths" in non-length-testing functions
: test_transitions_per_property says "interpolation of lengths" in non-length-t...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Daniel Holbert [:dholbert]
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-01 18:30 PDT by Daniel Holbert [:dholbert]
Modified: 2012-02-01 13:59 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
trivial fix (3.55 KB, patch)
2011-11-01 18:34 PDT, Daniel Holbert [:dholbert]
dbaron: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-11-01 18:30:35 PDT
While adding to test_transitions_per_property.html, I noticed that it's got "interpolation of lengths" as part of the subtest-description for some non-length properties.

In particular, the hits in test_zindex_transition() and test_pos_integer_or_auto_transition() are incorrect.  (those are testing interpolation of integer values, not lengths)

http://mxr.mozilla.org/mozilla-central/source/layout/style/test/test_transitions_per_property.html?force=1#852
http://mxr.mozilla.org/mozilla-central/source/layout/style/test/test_transitions_per_property.html?force=1#970
Comment 1 Daniel Holbert [:dholbert] 2011-11-01 18:34:30 PDT
Created attachment 571212 [details] [diff] [review]
trivial fix
Comment 2 Daniel Holbert [:dholbert] 2011-11-01 18:35:18 PDT
These chunks are used for testing the properties "z-index" and "-moz-column-count", FWIW.
Comment 3 David Baron :dbaron: ⌚️UTC-10 2011-12-06 16:33:43 PST
Comment on attachment 571212 [details] [diff] [review]
trivial fix

r=dbaron, though I'd actually have done "interpolation of z-index" and "interpolation of font-weight" since the functions are specific to those.  Feel free to do it that way.
Comment 4 Daniel Holbert [:dholbert] 2011-12-06 16:59:28 PST
(In reply to David Baron [:dbaron] from comment #3)
> Comment on attachment 571212 [details] [diff] [review] [diff] [details] [review]
> trivial fix
> 
> r=dbaron, though I'd actually have done "interpolation of z-index" and
> "interpolation of font-weight" since the functions are specific to those. 

I'm going to stick with "integers", if that's all right with you (sounds like it is), because:
 (1) while the first chunk (in "test_zindex_transition") is *currently* specific to z-index, it won't be for long.  I'm co-opting it to also test "flex-order" in the flex-order patch on bug 696253. (attachment 571221 [details] [diff] [review])

 (2) the second chunk ("test_pos_integer_or_auto_transition") is already used for multiple properties -- z-index and -moz-column-count, in particular.  (It's not used for font-weight -- that's only mentioned in the patch header-line because it's the function immediately *before* test_pos_integer_or_auto_transition)
Comment 5 Daniel Holbert [:dholbert] 2011-12-06 17:08:59 PST
(meant to say -- thanks for the review!)
Comment 6 Daniel Holbert [:dholbert] 2011-12-06 18:51:58 PST
Pushed:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/ad09520aac4b

(I pushed as DONTBUILD since this is only tweaking warning-strings within a mochitest, which can't affect test-behavior at all.)
Comment 7 Ed Morley [:emorley] 2011-12-07 02:30:19 PST
https://hg.mozilla.org/mozilla-central/rev/ad09520aac4b

Note You need to log in before you can comment on or make changes to this bug.