The default bug view has changed. See this FAQ.

Near-permaorange Android TEST-UNEXPECTED-FAIL | canvas/image-rendering-test.html | image comparison (==)

RESOLVED FIXED in mozilla11

Status

()

Core
Canvas: 2D
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
mozilla11
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 571248 [details]
reftest log

https://tbpl.mozilla.org/php/getParsedLog.php?id=7156947&tree=Mozilla-Inbound
Android Tegra 250 mozilla-inbound opt test reftest-1 on 2011-11-01 22:05:54 PDT for push 93625e3af8bc

REFTEST TEST-START | http://10.250.48.212:30102/tests/layout/reftests/canvas/image-rendering-test.html | 2752 / 3583 (76%)
REFTEST TEST-START | http://10.250.48.212:30102/tests/layout/reftests/canvas/image-rendering-ref.html | 2752 / 3583 (76%)
REFTEST TEST-UNEXPECTED-FAIL | http://10.250.48.212:30102/tests/layout/reftests/canvas/image-rendering-test.html | image comparison (==) 
...
REFTEST number of differing pixels: 40000
REFTEST INFO | Saved log: START http://10.250.48.212:30102/tests/layout/reftests/canvas/image-rendering-test.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Saved log: START http://10.250.48.212:30102/tests/layout/reftests/canvas/image-rendering-ref.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 47

5 years ago
In the hypothetical case where someone might notice this became permaorange across trees with no code connection this morning: the most likely thing among the releng changes that landed today is splitting reftests into 3 chunks instead of 2, with the probable result that whatever earlier test this was relying on after-effects from to be able to (sometimes) pass is no longer part of the same hunk as this one.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Summary: Intermittent Android TEST-UNEXPECTED-FAIL | canvas/image-rendering-test.html | image comparison (==) → Permaorange Android TEST-UNEXPECTED-FAIL | canvas/image-rendering-test.html | image comparison (==)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 65

5 years ago
Annotated as failing on Android in https://hg.mozilla.org/integration/mozilla-inbound/rev/4bdff61214c0 (not that that will help aurora, or beta, or release).
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Phil Ringnalda (:philor) from comment #65)
> Annotated as failing on Android in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/4bdff61214c0 (not
> that that will help aurora, or beta, or release).

https://hg.mozilla.org/mozilla-central/rev/4bdff61214c0
Target Milestone: --- → mozilla11
so in the test image, we show a blank white image, and the reference shows a green square surrounded by a red square.

The differences here are:

Test File:
<html reftest-zoom="2">
  <canvas style="image-rendering: -moz-crisp-edges; " id="canvas" width="300" height="300"></canvas>


reference file:
  <canvas id="canvas" width="300" height="300"></canvas>



so why is one of these two causing a failure:
* style="image-rendering: -moz-crisp-edges; "
* reftest-zoom="2"

Unfortunately we have both of these defined in layout/reftests/image/background-image-zoom-1.html and that test seems to be passing just fine in reftest2 chunk.

The big difference is that we are testing a canvas vs html for the style.

Comment 70

5 years ago
Created attachment 575429 [details] [diff] [review]
patch

maybe the zoom happens after the canvas has been drawn on Android. In which case this should fix it.
I can try this patch out a bit later this morning.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
odd, I am unable to reproduce this problem on inbound.  I pulled out the skip-if(Android) and couldn't get it to fail.  I have tried running it standalone, in a directory, and as a chunk
also I tested with the patch on this bug and the tests passed just fine.  If we feel this would be a good patch to land and the test would be just as effective, then lets review this and run it through try server.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 78

5 years ago
Sent to try, passed on on Android.

Updated

5 years ago
Attachment #575429 - Flags: review?(dholbert)
Attachment #575429 - Flags: review?(dholbert) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 81

5 years ago
Perma, Almostperma, who can tell the difference?
Summary: Permaorange Android TEST-UNEXPECTED-FAIL | canvas/image-rendering-test.html | image comparison (==) → Near-permaorange Android TEST-UNEXPECTED-FAIL | canvas/image-rendering-test.html | image comparison (==)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 84

5 years ago
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/d84b129b9936
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Robert Longson from comment #84)
> pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/d84b129b9936

https://hg.mozilla.org/mozilla-central/rev/d84b129b9936
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
can we land this patch on aurora as well?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 144

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=7775205&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=7776709&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=7781278&tree=Mozilla-Aurora
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Still getting lots of these failures, reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 158

5 years ago
Not on the trunk we aren't, just down in the depths of the release train.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Since this patch is a test-only change, can we land this on mozilla-beta to get rid of the permaorange there?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 575429 [details] [diff] [review]
patch

Does this patch apply to the ESR as well? If so, it would be good to take the fix there as well to prevent the perma-orange.
Comment hidden (Treeherder Robot)
(In reply to Alex Keybl [:akeybl] from comment #291)
> Does this patch apply to the ESR as well? If so, it would be good to take
> the fix there as well to prevent the perma-orange.

Thanks for the heads-up on that.  Indeed, the patch does apply to ESR.  (minus the removal of the "random" annotation in reftest.list, but that's fine -- ESR just never got that annotation in the first place (which is why it's still turning the tree orange).)

I pushed longsonr's patch to ESR, with a=tests-only:
  https://hg.mozilla.org/releases/mozilla-esr10/rev/7a5868ec89c9
(Assignee)

Updated

4 years ago
Keywords: intermittent-failure
(Assignee)

Updated

4 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.