Last Comment Bug 699233 - Misleading safe-mode UI misleads users during troubleshooting
: Misleading safe-mode UI misleads users during troubleshooting
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 14:32 PDT by VanillaMozilla
Modified: 2012-01-20 15:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description VanillaMozilla 2011-11-02 14:32:12 PDT
The safe-mode dialog says "Firefox is now running in Safe Mode, which temporarily disables your custom settings, themes, and extensions."

Unfortunately, this is not true.  Toolbar customizations are disabled, but all options set through the options menu or about:config are apparently still in effect in safe mode.

I checked that (1) there is no 'user.js' file and (2) the options are not just shown on the UI, but are actually in effect.  There's more discussion of this here:  http://forums.mozillazine.org/viewtopic.php?f=9&t=2351693&p=11420027#p11420027

A suggested revision would be "Firefox is now running in Safe Mode, which temporarily disables your themes, extensions, and toolbar customizations."

Bug occurs in version 7.0.1 under Windows and Linux.
Comment 1 Jennifer Morrow [:Boriss] (UX) 2012-01-20 15:00:34 PST
This is a good point, and the string has actually been changed since the filing of this bug.  It no longer mentions that your settings will be temporarily disabled.  Thanks for filing, Vanilla!

Note You need to log in before you can comment on or make changes to this bug.