Last Comment Bug 699240 - Ctrl+F4 should not close App Tabs
: Ctrl+F4 should not close App Tabs
Status: RESOLVED FIXED
[fixed-in-fx-team]
: ux-error-prevention
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: unspecified
: All Windows XP
: -- normal (vote)
: Firefox 10
Assigned To: (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 14:57 PDT by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2011-11-03 18:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug 699240 (1015 bytes, patch)
2011-11-02 15:42 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
no flags Details | Diff | Review
Patch for bug 699240 (963 bytes, patch)
2011-11-02 16:24 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
gavin.sharp: review+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-02 14:57:01 PDT
When closing many tabs, it is easy to hold down ctrl+f4. The tabs close fast, but App Tabs (which are promoted to a higher-class, longer-living tab) are also closed by ctrl+f4.

To prevent user errors, we shouldn't allow ctrl+f4 to close app tabs.
Comment 1 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-02 15:42:10 PDT
Created attachment 571484 [details] [diff] [review]
Patch for bug 699240

I ran the mochitest-browser-chrome tests locally with no failures.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-02 15:57:07 PDT
Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=00930bf79d18
Comment 3 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-02 16:24:12 PDT
Created attachment 571500 [details] [diff] [review]
Patch for bug 699240

Removed the check for ctrlPageUpPageDown since it is unnecessary based on this comment: https://bugzilla.mozilla.org/show_bug.cgi?id=628918#c1

Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=a41e006b29e0
Comment 4 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-02 19:21:46 PDT
Fixed in fx-team: https://hg.mozilla.org/integration/fx-team/rev/73e8ca9230d6
Comment 5 Rob Campbell [:rc] (:robcee) 2011-11-03 05:49:18 PDT
backed-out in: https://hg.mozilla.org/mozilla-central/rev/2be7246491d5

wrong commit message.
Comment 6 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-03 12:24:27 PDT
Repushed with fixed commit message: https://hg.mozilla.org/integration/fx-team/rev/ae7e205b7dc4
Comment 7 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-03 18:45:43 PDT
https://hg.mozilla.org/mozilla-central/rev/ae7e205b7dc4

Note You need to log in before you can comment on or make changes to this bug.