Last Comment Bug 699298 - Add GC timing data for TI sweeping and XPConnect
: Add GC timing data for TI sweeping and XPConnect
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: [PTO to Dec5] Bill McCloskey (:billm)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 17:28 PDT by [PTO to Dec5] Bill McCloskey (:billm)
Modified: 2011-12-04 17:31 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (10.09 KB, patch)
2011-11-02 17:28 PDT, [PTO to Dec5] Bill McCloskey (:billm)
no flags Details | Diff | Splinter Review
patch v2 (21.50 KB, patch)
2011-11-03 13:39 PDT, [PTO to Dec5] Bill McCloskey (:billm)
anygregor: review+
Details | Diff | Splinter Review

Description [PTO to Dec5] Bill McCloskey (:billm) 2011-11-02 17:28:32 PDT
Created attachment 571519 [details] [diff] [review]
patch

This does as it says. It also makes it a little easier to add new fields without having to worry about column alignment.
Comment 1 [PTO to Dec5] Bill McCloskey (:billm) 2011-11-03 11:09:57 PDT
Comment on attachment 571519 [details] [diff] [review]
patch

I had an idea for an improvement to this. I'll post a new patch soon.
Comment 2 [PTO to Dec5] Bill McCloskey (:billm) 2011-11-03 13:39:53 PDT
Created attachment 571762 [details] [diff] [review]
patch v2

This patch improves on the previous one by putting the MOZ_GCTIMER data into the Error Console (replacing the somewhat wrong data that was there before).

While I was at it, I also fixed the problem we have where we incorrectly think that all GCs are full GCs. With the fix, we will no longer run the cycle collector after a compartmental GC.

Gregor, do you have time to review this? Chris said his queue is pretty full.
Comment 3 [PTO to Dec5] Bill McCloskey (:billm) 2011-11-09 13:35:35 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/698e6ec3467e
Comment 4 Marco Bonardo [::mak] 2011-11-10 03:23:06 PST
https://hg.mozilla.org/mozilla-central/rev/698e6ec3467e
Comment 5 Marco Bonardo [::mak] 2011-11-10 03:26:41 PST
and follow-up
https://hg.mozilla.org/mozilla-central/rev/b5373c0d5a88
Comment 6 Olli Pettay [:smaug] 2011-12-04 13:55:51 PST
/me mumbles something about a patch to dom/ not getting a review from a DOM peer.

May I ask what the GC numbers mean ?
Comment 7 Olli Pettay [:smaug] 2011-12-04 13:56:40 PST
Especially, is the "Total" the total time in ms?
Comment 8 [PTO to Dec5] Bill McCloskey (:billm) 2011-12-04 17:31:51 PST
(In reply to Olli Pettay [:smaug] from comment #6)
> /me mumbles something about a patch to dom/ not getting a review from a DOM
> peer.
> 
> May I ask what the GC numbers mean ?

Uh, sorry. I thought nsJSEnvironment.cpp was a special case.

The numbers are in milliseconds. I can add units, since I guess it is a little confusing. Mark and Sweep are the time to do marking and sweeping. The remaining numbers mostly just break down the sweeping number. +Chu and -Chu tell you how many GC chunks were allocated or freed since the last GC.

Note You need to log in before you can comment on or make changes to this bug.