Last Comment Bug 699300 - Second external URL request does not open page
: Second external URL request does not open page
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Gian-Carlo Pascutto [:gcp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 17:38 PDT by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2012-01-09 11:28 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments

Description Lawrence Mandel [:lmandel] (use needinfo) 2011-11-02 17:38:38 PDT
I have been testing the native UI browser with the built in FriendStream app on my HTC Desire. The first time I click on a link in FriendStream Firefox launches and opens the page as expected. If I then return to FriendStream and click on another link Firefox launches but does not open the page. I am instead shown the previous page from my first link. (The page does not reload).

Steps to reproduce:
1. Force stop nightly if running.
2. Open FriendStream and click on a link in a tweet. Firefox nightly launches and opens the page.
3. Click the back button to return from nightly to FriendStream.
4. Click on a different link in a FriendStream. Nightly launches but does not change the page. The page from the link in 2 is still shown.

Expected result:
When I click on the link in 4 I expect that URL to be opened in the browser.

Actual result:
The page from the URL in 2, which was previously loaded, is still displayed.
Comment 1 Doug Turner (:dougt) 2011-11-02 23:45:32 PDT
can you retest?  I may have fixed this with:

http://hg.mozilla.org/projects/birch/rev/c09a52af4cd8
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2011-11-03 10:21:45 PDT
Happy to retest as soon as I get a new build. Not that I found this after updating (via prompt to update) last night.
Comment 3 Lawrence Mandel [:lmandel] (use needinfo) 2011-11-03 19:26:09 PDT
Rereading my previous comment, the last line should have read:

NOTE that I found...

I retested with a newer build and can not reproduce the issue. Looks like your fix was good. I have resolved as fixed.
Comment 4 Catalin Suciu [:csuciu] 2011-11-23 05:39:35 PST
Verified fixed on the latest fennec native build:
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111122 Firefox/11.0a1 Fennec/11.0a1
Samsung GalaxyS, Android 2.2

Note You need to log in before you can comment on or make changes to this bug.