The default bug view has changed. See this FAQ.

[highlighter] highlighter closes during iframe requests

VERIFIED FIXED in Firefox 10

Status

()

Firefox
Developer Tools
P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: rc, Assigned: msucan)

Tracking

Trunk
Firefox 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-fx-team][[testday-20111125]])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
STR:

1. open a page with AJAX on it. (e.g., http://arstechnica.com/apple/news/2011/11/stale-mac-pro-lineup-has-pro-users-concerned.ars)
2. open the highlighter
3. wait.

Expected:

highligher stays up.

Actual:

When an XMLRPC request fires, the highlighter closes.
(Assignee)

Comment 1

6 years ago
This is caused by the InspectorProgressListener, see onStateChange():

    // If the request is about to happen in a new window, we are not concerned
    // about the request.
    if (aProgress.DOMWindow != this.IUI.win) {
      return;
    }

The check above is not sufficient.
(Assignee)

Updated

6 years ago
Summary: [highlighter] highlighter closes during xmlrpc requests → [highlighter] highlighter closes during iframe requests
(Assignee)

Comment 2

6 years ago
Created attachment 572216 [details] [diff] [review]
proposed fix

This is the proposed fix. We just needed more fine-tuning of filtering the states. Please test and let me know if this patch fixes the problem. It does on my system.

The patch is missing a test because (1) it's late here and (2) we can't run mochitests anymore.

If we get a fix for running mochitests by tomorrow or Monday, I'd happily write a test for this patch.

Given the importance of this fix we should try as much as possible to land this in time for fx10.

Looking forward for your feedback. Thank you!
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Attachment #572216 - Flags: feedback?(rcampbell)
(Assignee)

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Comment 3

6 years ago
tests should be fixed now if you repull from m-c or fx-team.

I'll test this locally and give it a read through. Thanks!
(Reporter)

Comment 4

6 years ago
Comment on attachment 572216 [details] [diff] [review]
proposed fix

This tested well here. I ran it against Yahoo's front page and moused over the middle part of the page that has the different stories associated with pictures and the Highlighter stayed up. I'll look around on a couple of other sites I was seeing this happening on, but I think this'll work.
Attachment #572216 - Flags: feedback?(rcampbell) → feedback+
(Reporter)

Updated

6 years ago
Priority: -- → P1
(Assignee)

Comment 5

6 years ago
Created attachment 572293 [details] [diff] [review]
fix + test

Updated patch. Added a mochitest. Two javascript:location.reload() calls in the iframe are sufficient to trigger the bug.

Looking forward for your review. Thank you!

(asking both for review, I don't know who has time to get to review the patch sooner)
Attachment #572216 - Attachment is obsolete: true
Attachment #572293 - Flags: review?(rcampbell)
Attachment #572293 - Flags: review?(dcamp)
(Reporter)

Comment 6

6 years ago
Comment on attachment 572293 [details] [diff] [review]
fix + test

yup!
Attachment #572293 - Flags: review?(rcampbell) → review+

Comment 7

6 years ago
https://hg.mozilla.org/integration/fx-team/rev/ec6b4d73b906
Whiteboard: [fixed-in-fx-team]
(Reporter)

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/ec6b4d73b906
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10

Updated

5 years ago
Attachment #572293 - Flags: review?(dcamp)

Comment 9

5 years ago
Verified fixed using
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111124 Firefox/10.0a2
and
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a2) Gecko/20111123 Firefox/10.0a2
Status: RESOLVED → VERIFIED
Whiteboard: [fixed-in-fx-team] → [fixed-in-fx-team][[testday-20111125]]
You need to log in before you can comment on or make changes to this bug.