Last Comment Bug 699475 - Integrate RuleView into Highlighter Sidebar
: Integrate RuleView into Highlighter Sidebar
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Rob Campbell [:rc] (:robcee)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-03 10:52 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-11-05 06:17 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP 1 (4.57 KB, patch)
2011-11-03 10:53 PDT, Rob Campbell [:rc] (:robcee)
no flags Details | Diff | Splinter Review
WIP 2 (5.18 KB, patch)
2011-11-03 11:57 PDT, Rob Campbell [:rc] (:robcee)
no flags Details | Diff | Splinter Review
RuleView in Sidebar (7.54 KB, patch)
2011-11-03 13:39 PDT, Rob Campbell [:rc] (:robcee)
dcamp: review+
Details | Diff | Splinter Review
Mac Screenshot (814.64 KB, image/png)
2011-11-03 14:26 PDT, Rob Campbell [:rc] (:robcee)
no flags Details
RuleView in Sidebar 2 (13.59 KB, patch)
2011-11-04 08:51 PDT, Rob Campbell [:rc] (:robcee)
dcamp: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-11-03 10:52:22 PDT
Add the cssRuleView to the Highlighter's Sidebar.
Comment 1 Rob Campbell [:rc] (:robcee) 2011-11-03 10:53:45 PDT
Created attachment 571709 [details] [diff] [review]
WIP 1
Comment 2 Rob Campbell [:rc] (:robcee) 2011-11-03 11:57:06 PDT
Created attachment 571728 [details] [diff] [review]
WIP 2

behavior seems to be fixed, added entries to inspector.properties for strings. Just haven't checked the tests yet.
Comment 3 Rob Campbell [:rc] (:robcee) 2011-11-03 13:39:06 PDT
Created attachment 571761 [details] [diff] [review]
RuleView in Sidebar

Updated patch, added unittests, cleanup code and improved functionality.
Comment 4 Rob Campbell [:rc] (:robcee) 2011-11-03 14:26:53 PDT
Created attachment 571776 [details]
Mac Screenshot
Comment 5 Rob Campbell [:rc] (:robcee) 2011-11-03 14:36:22 PDT
Comment on attachment 571776 [details]
Mac Screenshot

wrong place for the screenshot.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-11-03 14:41:39 PDT
https://hg.mozilla.org/integration/fx-team/rev/b878369ab3c8
Comment 7 Rob Campbell [:rc] (:robcee) 2011-11-03 16:29:20 PDT
https://hg.mozilla.org/integration/fx-team/rev/87ce80260f22
Comment 8 Rob Campbell [:rc] (:robcee) 2011-11-04 08:51:43 PDT
Created attachment 571994 [details] [diff] [review]
RuleView in Sidebar 2

Updated version. More tests. Checks for and disables extra set buttons in sidebar. Tests tab switching with sidebar tools active.
Comment 9 Rob Campbell [:rc] (:robcee) 2011-11-04 08:54:54 PDT
current try build running here:

https://tbpl.mozilla.org/?tree=Try&rev=4bfaea2d57cb
Comment 10 Rob Campbell [:rc] (:robcee) 2011-11-04 10:49:22 PDT
relanded:

https://hg.mozilla.org/integration/fx-team/rev/482f32dcd1eb
Comment 11 Rob Campbell [:rc] (:robcee) 2011-11-05 06:17:09 PDT
https://hg.mozilla.org/mozilla-central/rev/482f32dcd1eb

Note You need to log in before you can comment on or make changes to this bug.