Last Comment Bug 699516 - Rename WEBKIT_lose_context to WEBGL_EXT_lose_context
: Rename WEBKIT_lose_context to WEBGL_EXT_lose_context
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-03 12:06 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-11-04 03:09 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rename to MOZ_lose_context (2.41 KB, patch)
2011-11-03 12:06 PDT, Benoit Jacob [:bjacob] (mostly away)
bugzilla: review-
Details | Diff | Splinter Review
rename to MOZ_lose_context (3.26 KB, patch)
2011-11-03 12:25 PDT, Doug Sherk (:drs) (inactive)
bugzilla: review+
Details | Diff | Splinter Review
rename to WEBGL_EXT_lose_context (4.22 KB, patch)
2011-11-03 17:21 PDT, Benoit Jacob [:bjacob] (mostly away)
bugzilla: review+
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-11-03 12:06:21 PDT
Created attachment 571732 [details] [diff] [review]
rename to MOZ_lose_context

Jeff M mentioned that it's actually a bad idea for us to expose WEBKIT_ prefixed extensions, and it's better for everybody to rename them to MOZ_. The idea is that this way, web devs can rely on WEBKIT_ stuff being actually, bug for bug, WebKit, rather than having to use e.g. user agent strings.
Comment 1 Jeff Gilbert [:jgilbert] 2011-11-03 12:14:50 PDT
But as per the khronos list discussion, since we're using the same standard as WebKit, shouldn't we be naming this EXT_?
Comment 2 Doug Sherk (:drs) (inactive) 2011-11-03 12:20:17 PDT
Comment on attachment 571732 [details] [diff] [review]
rename to MOZ_lose_context

Review of attachment 571732 [details] [diff] [review]:
-----------------------------------------------------------------

Did you try building this? I think WebGLContext.h:529 was missed.
Comment 3 Doug Sherk (:drs) (inactive) 2011-11-03 12:25:29 PDT
Created attachment 571739 [details] [diff] [review]
rename to MOZ_lose_context
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-11-03 12:32:23 PDT
I just had another conversation with jrmuizel and there was a misunderstanding. He thought that was a prefix on a function name. For GL extensions, the norm is for vendors to use each others' extensions without renaming them, so we can stick with that.

-> not landing this patch for now.

However we still want to rename this to WEBGL_ or WEBGL_EXT_ soon.
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-11-03 12:51:40 PDT
(In reply to Jeff Gilbert [:jgilbert] from comment #1)
> But as per the khronos list discussion, since we're using the same standard
> as WebKit, shouldn't we be naming this EXT_?

I would like to bring this up in the next conference call. Unfortunately today's got cancelled, next one is in 2 weeks.
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-11-03 17:21:57 PDT
Created attachment 571847 [details] [diff] [review]
rename to WEBGL_EXT_lose_context

Per public_webgl list discussion, we're switching to WEBGL_EXT_ now.
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-11-03 17:34:06 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/2964292c2dc7
Comment 8 Ed Morley [:emorley] 2011-11-04 03:09:15 PDT
https://hg.mozilla.org/mozilla-central/rev/2964292c2dc7

Note You need to log in before you can comment on or make changes to this bug.