Last Comment Bug 699734 - Crash in xpcshell on sparc linux
: Crash in xpcshell on sparc linux
Status: RESOLVED FIXED
[inbound]
: crash
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: Sun Linux
: -- critical (vote)
: mozilla11
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 01:08 PDT by Mike Hommey [:glandium]
Modified: 2012-02-01 13:59 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Export the _IO_stdin_used symbol (718 bytes, patch)
2011-11-04 01:10 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-11-04 01:08:36 PDT
I got the craziest crash happening on sparc linux, when running xpcshell with jemalloc enabled, it crashes in "setbuf(stdout, 0);" (which is a libc function).

It turns out this is due to the fact that the _IO_stdin_used symbol is not exported, because of the version script used to hide most symbols from programs. No idea why this only crashes on sparc, though.
Comment 1 Mike Hommey [:glandium] 2011-11-04 01:10:19 PDT
Created attachment 571903 [details] [diff] [review]
Export the _IO_stdin_used symbol
Comment 3 Ed Morley [:emorley] 2011-11-19 05:16:51 PST
https://hg.mozilla.org/mozilla-central/rev/109b2416d243
Comment 4 Reuben Morais [:reuben] 2011-12-14 03:38:01 PST
This also affected x86 (https://crash-stats.mozilla.com/report/index/bp-696816ab-e67c-4beb-b60e-defec2111214 / https://launchpad.net/bugs/810214), should we ship this earlier than Firefox 11?

Note You need to log in before you can comment on or make changes to this bug.