Closed Bug 699792 Opened 8 years ago Closed 8 years ago

ALT key not working correctly on Motorola DROID PRO

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: camelia.urian, Assigned: alexp)

References

Details

(Whiteboard: [HKB])

Attachments

(1 file)

Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111104 Firefox/10.0a1 Fennec/10.0a1
Device: Motorola Droid Pro
OS: Android 2.2

Steps:
1. Start Fennec with a clear profile in portrait mode.
2. Go to www.google.com
3. Tap on search field, press ALT key once  and let go of the key
4. Press a key that would give you a number or a special character

Actual results:  Letter appears in text field.
Expected result: Number/special character appears in text field.

5. Press ALT key twice to lock ALT function.
6. Press 2 keys that would give you numbers or a special characters.

Actual results:  Letters appear in text field.
Expected result: Numbers/special characters appear in text field.

Notes:
- I tried Multi-touch  and OpenWnn keyboards, same results on both.
- ALT key works correctly on Android browser.
- SHIFT key works correctly on both Android browser and Fennec
- This could be regression from bug #599811
AlexP is this something important.
Assignee: nobody → alexp
Status: NEW → ASSIGNED
Whiteboard: [HKB]
Attached patch FixSplinter Review
Looks like a mistake was made when the check for the ALT meta state was implemented the first time.
Tested the fix on Droid Pro and Droid 3 - ALT is working properly now.
Attachment #574758 - Flags: review?(blassey.bugs)
Attachment #574758 - Flags: review?(blassey.bugs) → review+
http://hg.mozilla.org/projects/birch/rev/5352c48874e2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111122 Firefox/11.0a1 Fennec/11.0a1 - Native build
Device: Motorola DROID PRO
OS: Android 2.3

Both ALT and SHIFT keys work ok.
Status: RESOLVED → VERIFIED
Depends on: 772252
You need to log in before you can comment on or make changes to this bug.