Last Comment Bug 699793 - Clear favicon urls database when history is cleared
: Clear favicon urls database when history is cleared
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
P3 normal (vote)
: Firefox 12
Assigned To: Lucas Rocha (:lucasr)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 07:33 PDT by Lucas Rocha (:lucasr)
Modified: 2016-07-29 14:20 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
Clear favicon urls database when history is cleared (2.63 KB, patch)
2011-11-09 11:47 PST, Lucas Rocha (:lucasr)
blassey.bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Lucas Rocha (:lucasr) 2011-11-04 07:33:16 PDT
We have a separate database that holds favicons urls that should be cleared when user clears its browsing history data.
Comment 1 User image Lucas Rocha (:lucasr) 2011-11-09 11:47:41 PST
Created attachment 573269 [details] [diff] [review]
Clear favicon urls database when history is cleared
Comment 2 User image Lucas Rocha (:lucasr) 2011-11-10 03:35:36 PST
Pushed: http://hg.mozilla.org/projects/birch/rev/0677f937cf3b
Comment 3 User image Wesley Johnston (:wesj) 2011-11-10 10:41:19 PST
These patches were backed while investigating Talos failures.  Now that tests are green again, we will need to reland.
Comment 4 User image Brad Lassey [:blassey] (use needinfo?) 2011-11-11 08:53:27 PST
backout was backed out https://hg.mozilla.org/projects/birch/rev/6f925b45a547
Comment 5 User image Damon Sicore (:damons) 2011-11-13 14:15:40 PST
Where are the tests for this?
Comment 6 User image Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-11-13 19:25:51 PST
Question: should all favicons icons be cleared?  What about the default bookmarks and search engines?
Comment 7 User image Lucas Rocha (:lucasr) 2011-11-14 02:41:04 PST
(In reply to Damon Sicore (:damons) from comment #5)
> Where are the tests for this?

Damon, we don't have a unit test infra in place to start adding tests yet. I'd suggest to file a bug to add the infra for tests on native UI and set a high priority for it.
Comment 8 User image Lucas Rocha (:lucasr) 2011-11-14 03:41:01 PST
(In reply to Naoki Hirata :nhirata from comment #6)
> Question: should all favicons icons be cleared?  What about the default
> bookmarks and search engines?

The favicon images won't be removed for bookmarks because their entries in the database are kept. This means that the favicons should still be visible in the bookmarks tab even after history is cleared.

What will happen though is that the favicon URLs for the bookmarks will be cleared. So when they are accessed for the first time after history was cleared, the favicon will be downloaded again even though the image is still present in the database (which is not a big deal).
Comment 9 User image Aaron Train [:aaronmt] 2011-11-14 06:15:25 PST
20111114041052
http://hg.mozilla.org/projects/birch/rev/859ecdfe0168
Samsung Galaxy SII (Android 2.3.4)
Comment 10 User image Kartikaya Gupta (email:kats@mozilla.com) 2011-12-08 14:10:58 PST
This patch was reverted in birch as part of the backout, but never got put back because the commits following the backout-of-the-backout used a different changeset as parent. The code is NOT in m-c now and the patch should be re-landed.
Comment 11 User image Kartikaya Gupta (email:kats@mozilla.com) 2011-12-22 12:11:06 PST
Reopening, see my previous comment.
Comment 12 User image Lucas Rocha (:lucasr) 2012-01-13 08:22:27 PST
Relanded:
http://hg.mozilla.org/integration/mozilla-inbound/rev/23099bd5d462
Comment 13 User image Lucas Rocha (:lucasr) 2012-01-13 08:23:12 PST
Comment on attachment 573269 [details] [diff] [review]
Clear favicon urls database when history is cleared

This patch clears data that is supposed to be removed when history is cleared.
Comment 14 User image Marco Bonardo [::mak] 2012-01-14 01:43:23 PST
https://hg.mozilla.org/mozilla-central/rev/23099bd5d462
Comment 15 User image Alex Keybl [:akeybl] 2012-01-16 12:59:34 PST
Comment on attachment 573269 [details] [diff] [review]
Clear favicon urls database when history is cleared

[Triage Comment]
Mobile only - approved for Aurora.
Comment 16 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-16 22:48:58 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/a4c0f729f35e

Note You need to log in before you can comment on or make changes to this bug.