Closed Bug 699816 Opened 10 years ago Closed 10 years ago

addon install progress bar hangs

Categories

(Toolkit :: Add-ons Manager, defect)

8 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 689375

People

(Reporter: kumar, Unassigned)

Details

STR:
- Go to addons.mozilla.org
- Click the install button on an addon

Results:
The progress bar shows the addon downloading but when it completes it just hangs forever.  If I click the same install button a second time, the permission dialog pops up (like normal) letting me continue with the installation.  This same behavior happens every time.  If I install from the builtin addons manager the same thing happens except I have to open AMO and click the install button to complete installation.

This does *not* happen on a clean profile so obviously it's something with my default profile (the one with all my history, the one I use for everyday browsing).

Does anyone have any tips for how to fix up my profile so this doesn't happen?  Or maybe a tip to debug what's going on here?
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: extension.compatibility → add-ons.manager
I've had the same problem in my add-on testing profile. When I install an add-on, the download begins and reaches 100%, but nothing happens after that. Canceling and restarting the installation finished immediately and correctly. In those cases I've also noticed that opening the Add-ons Manager shows a weird empty add-on entry in a "Downloading" state.

I suspect this happens if you're using the same profile with different Firefox versions, possibly some combination of 7, 8 and 9, but that's just speculation.

IIRC, there's an error that appears in the Error Console when this happens. Kumar, can you see the same error, and if so, can you add it here?
What versions of Firefox are you testing? I think this might just be bug 689375
It could be, yes. If this is the same bug, it should be fixed with the latest beta release, correct?
(In reply to Jorge Villalobos [:jorgev] from comment #3)
> It could be, yes. If this is the same bug, it should be fixed with the
> latest beta release, correct?

I don't think a beta got built with it, but you'd be seeing SQL errors in the error console mentioning AddonRepository.
Oh, I wasn't on the latest beta and updating it fixed the problem.  Thanks!  It sounds like a dupe of bug 689375
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689375
You need to log in before you can comment on or make changes to this bug.