Last Comment Bug 699832 - Style Inspector needs a way to display treetwisties that will work on all operating systems
: Style Inspector needs a way to display treetwisties that will work on all ope...
Status: RESOLVED FIXED
[styleinspector]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
: 697399 (view as bug list)
Depends on:
Blocks: 699762
  Show dependency treegraph
 
Reported: 2011-11-04 09:51 PDT by Michael Ratcliffe [:miker] [:mratcliffe]
Modified: 2012-03-07 05:03 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple html file that uses treetwisties (2.26 KB, text/html)
2011-11-04 09:51 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details
It surely can't be so easy ... can it (2.30 KB, text/html)
2011-11-04 10:29 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details
No, Ubuntu was awkward but now this works fine (2.31 KB, text/html)
2011-11-04 11:16 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
no flags Details
WIP (8.70 KB, patch)
2011-11-06 07:24 PST, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch (9.13 KB, patch)
2011-11-06 10:26 PST, Dão Gottwald [:dao]
dcamp: review+
Details | Diff | Splinter Review

Description Michael Ratcliffe [:miker] [:mratcliffe] 2011-11-04 09:51:16 PDT
Created attachment 572011 [details]
Simple html file that uses treetwisties

We simply need to find a way to display them that does not depend on the size of the image
Comment 1 Michael Ratcliffe [:miker] [:mratcliffe] 2011-11-04 09:53:44 PDT
*** Bug 697399 has been marked as a duplicate of this bug. ***
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2011-11-04 10:29:26 PDT
Created attachment 572018 [details]
It surely can't be so easy ... can it

Ideally we need people to test the attached file on all OSes.
Comment 3 Michael Ratcliffe [:miker] [:mratcliffe] 2011-11-04 11:16:24 PDT
Created attachment 572025 [details]
No, Ubuntu was awkward but now this works fine

So we can use this for (gnome|pin)stripe and grab the images directly in windows
Comment 4 Dão Gottwald [:dao] 2011-11-06 07:24:40 PST
Created attachment 572300 [details] [diff] [review]
WIP

This works on Linux. I haven't tested OS X and Windows yet.
Comment 5 Dão Gottwald [:dao] 2011-11-06 10:26:55 PST
Created attachment 572311 [details] [diff] [review]
patch
Comment 7 Rob Campbell [:rc] (:robcee) 2011-11-07 07:01:40 PST
https://hg.mozilla.org/mozilla-central/rev/232756b8af4d

Note You need to log in before you can comment on or make changes to this bug.