Update the Windows RDF for the Flash Player 11.1.102.55 Update

RESOLVED FIXED

Status

Toolkit Graveyard
Plugin Finder Service
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: John Pfeiffer, Assigned: Tomcat)

Tracking

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.9
Build ID: 20110920075126

Steps to reproduce:

Update the Windows RDF for the Flash Player 11.1.102.55 Update.


Actual results:

Flash Player 11.1.102.55 will be released on Thursday 11/10/2011 at 10am PST. Please update the PFS RDF for Windows at that time. Here are the RDF configuration changes (note we now have both 32-bit and 64-bit installers):



Expected results:

RDF changes for 32-bit Windows systems:

<pfs:version>11.1.102.55</pfs:version>
<pfs:InstallerLocation>http://download.macromedia.com/pub/flashplayer/current/FP_PL_PFS_INSTALLER_32bit.exe</pfs:InstallerLocation>
<pfs:InstallerHash>sha256:de413e759589b387bfa17852a91e752e0318104998e0e4bbddacd9972483ec12</pfs:InstallerHash>

RDF change for 64-bit Windows systems:

<pfs:version>11.1.102.55</pfs:version>
<pfs:InstallerLocation>http://download.macromedia.com/pub/flashplayer/current/FP_PL_PFS_INSTALLER_64bit.exe</pfs:InstallerLocation>
<pfs:InstallerHash>sha256:c31e5238b00b284e64969262161fd170a3288e34d3ddcc95b50b558de7a74744</pfs:InstallerHash>
Component: General → Plugin Finder Service
Product: Firefox → Toolkit
QA Contact: general → plugin.finder
Version: 3.6 Branch → unspecified

Updated

7 years ago
Duplicate of this bug: 701643
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
Created attachment 574255 [details] [diff] [review]
patch 32bit

taking this bug and created a patch (please bear with me its my first patch :))
Assignee: nobody → cbook
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Attachment #574255 - Flags: review?(morgamic)
Attachment #574255 - Flags: review?(kev)

Comment 3

7 years ago
Created attachment 574303 [details] [diff] [review]
Updated PFS to suppoert 32/64-bit Flash Player

From Comment #0, both the 32 and 64-bit installers are now supported. This patch adds support for offering the 64-bit Flash Player to 64-bit Firefox builds as well as updating the version to the latest version of Flash.

Tomcat has tested this version and it appears to function as expected. The new version can also be tested by setting the pfs.datasource.url pref to "http://kev.deadsquid.com/whafa/pfs.php?mimetype=%PLUGIN_MIMETYPE%&appID=%APP_ID%&appVersion=%APP_VERSION%&clientOS=%CLIENT_OS%&chromeLocale=%CHROME_LOCALE%&appRelease=%APP_RELEASE%"

Ready to apply and push.
Attachment #574255 - Attachment is obsolete: true
Attachment #574255 - Flags: review?(morgamic)
Attachment #574255 - Flags: review?(kev)
Attachment #574303 - Flags: review?(morgamic)
(Assignee)

Comment 4

7 years ago
(In reply to Kev [:kev] Needham from comment #3)
> Tomcat has tested this version and it appears to function as expected. The
> new version can also be tested by setting the pfs.datasource.url pref to
> "http://kev.deadsquid.com/whafa/pfs.
> php?mimetype=%PLUGIN_MIMETYPE%&appID=%APP_ID%&appVersion=%APP_VERSION%&client
> OS=%CLIENT_OS%&chromeLocale=%CHROME_LOCALE%&appRelease=%APP_RELEASE%"
> 


confirmed, testing worked well and passed the test on 64bit and 32bit - both flash versions were working
(Assignee)

Comment 5

7 years ago
ping, this seems to be waiting for review
Comment on attachment 574303 [details] [diff] [review]
Updated PFS to suppoert 32/64-bit Flash Player

Sorry guys, fell behind.  Indentation seems weird but otherwise is fine.  Any chance you could strip tabs?
Attachment #574303 - Flags: review?(morgamic) → review+

Comment 7

7 years ago
Created attachment 578322 [details] [diff] [review]
edits with tabbed stripped per comment #6

Comment 8

7 years ago
Created attachment 578323 [details] [diff] [review]
edits with tabbed stripped per comment #6

Let's try that again with vars defined properly.

Tabs stripped, indents no longer wonky, this should be gtg now.

Wil, can you push this version of the patch?
Attachment #578322 - Attachment is obsolete: true
Done in r98315.  Will go live today at 2.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 10

7 years ago
Thanks, Wil. Much appreciated, all.
(Assignee)

Comment 11

7 years ago
uhm seems we used the old version number here
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

7 years ago
Created attachment 594121 [details] [diff] [review]
patch to correct the version number
Attachment #594121 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #594121 - Flags: review? → review?(kev)
Tomcat: Is this still relevant ?
(Assignee)

Comment 14

6 years ago
(In reply to Matthias Versen (Matti) from comment #13)
> Tomcat: Is this still relevant ?

no, already superseded by new versions, thanks!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED

Comment 15

6 years ago
Comment on attachment 594121 [details] [diff] [review]
patch to correct the version number

Closing this off, as it's long been implemented
Attachment #594121 - Flags: review?(kev)
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.