Status

--
critical
RESOLVED DUPLICATE of bug 339805
7 years ago
3 months ago

People

(Reporter: Delineif, Unassigned)

Tracking

(Depends on: 1 bug, {dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build ID: 20110930092603

Steps to reproduce:

I'm using Thunderbird 7.0.1
I had been browsing some newsgroup.



Actual results:

Upon TB restart, susbscriptions were gone. Looking at the newsrc file, it was 0 bytes.

This can be correlated to the disk space filling up (unlike bug 403200, which requires it to be in a network share). Had seen it on previous releases, too.
The rc file needs to get restored from backup.



Expected results:

Check the return values. If you can't write to the file because the disk is full, keep the old one, so that new read messages won't get updated, but you won't lose all the previous ones.
Using the classic create with temp name, flush, sync, rename over old file (if there were no errors previously) should fix it.
(Reporter)

Updated

7 years ago
Keywords: dataloss

Updated

7 years ago
Severity: normal → critical
Whiteboard: [dupeme?]

Comment 1

3 months ago
Seems like this would have been a duplicate of bug 339805
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Depends on: 339805
Resolution: --- → DUPLICATE
See Also: → bug 403200
Duplicate of bug: 339805
You need to log in before you can comment on or make changes to this bug.