Last Comment Bug 700006 - [layers] about:home show dead space
: [layers] about:home show dead space
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: P1 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 701408 701793 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 20:49 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-01-09 14:50 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
screenshot (54.21 KB, image/png)
2011-11-04 20:49 PDT, Mark Finkle (:mfinkle) (use needinfo?)
no flags Details
patch (1.65 KB, patch)
2011-11-07 17:13 PST, Brian Nicholson (:bnicholson) (on PTO through June 3)
dougt: review+
Details | Diff | Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-11-04 20:49:46 PDT
Created attachment 572166 [details]
screenshot

Breaking this out of bug 700005

The about:home page has dead space at the bottom. See screenshot
Comment 1 Brian Nicholson (:bnicholson) (on PTO through June 3) 2011-11-07 17:13:23 PST
Created attachment 572681 [details] [diff] [review]
patch
Comment 2 Doug Turner (:dougt) 2011-11-09 15:52:46 PST
Comment on attachment 572681 [details] [diff] [review]
patch

Review of attachment 572681 [details] [diff] [review]:
-----------------------------------------------------------------

::: embedding/android/GeckoApp.java
@@ +830,5 @@
> +                int layoutWidth = mGeckoLayout.getMeasuredWidth();
> +                int layoutHeight = mGeckoLayout.getMeasuredHeight();
> +                // increase page size if smaller than layout dimensions
> +                if (size.width < layoutWidth || size.height < layoutHeight) {
> +                    size = new IntSize(Math.max(size.width, layoutWidth), Math.max(size.height, layoutHeight));

does it make sense to line wrap this?
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-10 09:59:13 PST
*** Bug 701408 has been marked as a duplicate of this bug. ***
Comment 4 Doug Turner (:dougt) 2011-11-10 20:43:46 PST
[Thu Nov 10 20:43:10 dougt@dougt:~/builds/birch ] $ hg qpush
applying attachment.cgi?id=572681
patching file embedding/android/GeckoApp.java
Hunk #1 FAILED at 820
1 out of 1 hunks FAILED -- saving rejects to file embedding/android/GeckoApp.java.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-14 08:17:46 PST
http://hg.mozilla.org/projects/birch/rev/772155060499
Comment 6 Tony Chung [:tchung] 2011-11-14 10:23:44 PST
*** Bug 701793 has been marked as a duplicate of this bug. ***
Comment 7 Catalin Suciu [:csuciu] 2011-11-16 05:46:19 PST
Verified fixed on Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111116
Firefox/11.0a1 Fennec/11.0a1

Note You need to log in before you can comment on or make changes to this bug.