Support for IMAP notes (Gmail/iCloud Notes)

RESOLVED DUPLICATE of bug 713843

Status

MailNews Core
Networking: IMAP
--
enhancement
RESOLVED DUPLICATE of bug 713843
7 years ago
6 years ago

People

(Reporter: Alex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111102223350

Steps to reproduce:

There is no support for editing notes in the "Notes" IMAP folders on Gmail/iCloud accounts (or indeed others). You should at least be able to edit messages in-place in the Notes folder, like in Drafts.



Expected results:

Please provide support for the editing of IMAP notes.
(Reporter)

Updated

7 years ago
Severity: normal → enhancement
> What is Gmail Notes? : http://gmailnotes.appspot.com/
> Where Gmail Notes Are Used : http://gmailnotes.appspot.com/3/static/site/html/uses.html
> To Start Using Gmail Notes : http://gmailnotes.appspot.com/3/static/site/html/gettingstarted.html
> What Gmail Notes Does NOT Do : http://gmailnotes.appspot.com/3/static/site/html/limitations.html

Google states "Gmail Notes" is supported by browser(currently Firefox only) with his add-on(extension). Even if data used by "Gmail Notes" is shown via Gmail IMAP to IMAP client as mail like data in Gmail IMAP folder(s), "mail format and/or format of data in mail" is not documented or not opened, and even if documented/opened, there is no garantee that "data update via IMAP clients"(==new mail upload + old mail deletion) will be surely used by Gmail/Gmail Note as you want.

What kind of enhancements of Tb(an IMAP client) based on what specs/documentations are you requesting by your "support for the editing of IMAP notes"?

"Editing of mail format data in mbox for Gmail Notes, like draft mail in [Gmail]/Drafts by IMAP client" is base of new Google's Gmail Notes extention for Thunderbid?
If so, I believe next is sufficient and is already available/usable.
- Add an identity, which points Gmail IMAP's Gmail Notes folder as draft folder
- Because of "folder to save draft for Tb", "Edit Draft" works as usual on this
  folder for your Gmail Notes, although stored flag is \Draft which may be
  different from your expectation.
(Reporter)

Comment 2

7 years ago
I'm not really expecting a separate UI for IMAP notes per se, but more of an editable folder for notes, very much how Apple Mail does it (which supports Gmail and iCloud notes, and perhaps generic IMAP notes, if such a thing exists).

It's interesting to hear of this feature for marking an IMAP folder as a "\Draft" folder. Could you elaborate more on how to do this please? Thanks.
(1) At any account defined in Tb(except Local Folders),
    Manage Identities, add an Identity(e.g. mail-addr=Gmail-Notes@gmail.notes),
    at Copies&Folders tab, choose Gmail IMAP account's "Gmail Notes" folder
    as draft folder to save draft.
(2) Open Gmail IMAP account's "Gmail Notes" folder,
    "Edit"("Edit As Drafft") of existent mail,
    Change From: to Gmail-Notes@gmail.notes, Save
Although "From: Gmail-Notes@gmail.notes" is forced by Tb and stored flag is \Draft, new version of "mail data" is uploaded by Tb.
Message-Id: may be changed upon upload of new version of draft for Tb.
(Reporter)

Comment 4

7 years ago
Thanks, although this does seem like quite a hack. Will proper support be coming any time soon??
See Also: → bug 713843
Summary: Support for IMAP notes → Support for IMAP notes (Gmail/iCloud Notes)
Bug 713843 is similar request for Apple's iCloud Notes.
Alex(bug opener), do you know difference between Apple's iCloud Notes and Gmail Notes?
(Reporter)

Comment 6

6 years ago
I'm afraid I don't really, but it would *seem* they are both simply IMAP folders named "Notes" with editable items.
(Reporter)

Comment 7

6 years ago
I suspect the only difference will be in headers, which we should be able to investigated quite easily?
If you provide us mail data(mail source) which Gmail Notes actually uses, we can compare it with mail source acually used by Apple's iCloud Notes, because, as seen in bug 713843 comment #8, bug opener of that bug already has mail source used by Apple's iCloud Notes.

Updated

6 years ago
Component: General → Networking: IMAP
OS: Windows 7 → All
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Hardware: x86_64 → All
(Reporter)

Comment 9

6 years ago
Alas, it seems it was Outlook 2010 and its not feature that I used to create these Gmail notes in the past. I no longer have Outlook installed, so can't experiment as such. Perhaps someone else could provide the relevant header information? I can't imagine it being *too* different -- perhaps only the header type?
Depends on: 713843
According to some Web pages found by Google search for "Gmail Notes", for example,
> http://googlesystem.blogspot.com/2010/06/save-iphone-notes-to-gmail-account.html
> http://lifehacker.com/5569758/seamlessly-sync-iphone-notes-to-a-gmail-account
iPhone after a firmware update of iOS4 looks to create Gmail IMAP folder named "Notes"(==Gmail Label named "Notes") and looks to upload iPhone's note to the Gmail IMAP "Notes" folder.

According to next Web page, Gmail Label named "Notes"(==Gmail IMAP folder named "Notes") sees commonly used by Gmail Notes, because next Web page doesn't look iPhone's Notes only description.
> http://www.ehow.com/how_3390962_add-notes-gmail.html
Above Web page refers to "{Your_User_Name_of_Gmail}+notes@gmail.com in To: header". This may be Gmail Notes's only spec, because, according to bug 713843 comment #5, "MUST NOT have a To: header" looks spec of iPhone's Notes.

Both Gmail Notes and Apple's iPhone Notes looks to utilize same Gmail Label named "Notes"(==Gmail IMAP folder named "Notes").
But it looks that spec of message header is different, because, according to bug 713843 comment #8, iPhone Notes requests "X-Uniform-Type-Identifier: com.apple.mail-note" header.
As bug opener of bug 713843 refers to "Content-Type: text/html" and "message body without <html> tag in HTML source" in iPhone Notes, spec of message body text may also be different between Gmail Notes and Apple's iPhone Notes.
(In reply to Alex from comment #0)
> There is no support for editing notes in the "Notes" IMAP folders on
> Gmail/iCloud accounts (or indeed others).

I perhaps misunderstood your "Notes" on "Gmail/iCloud accounts".

What service or feature or functionality do you call by "Gmail/iCloud accounts"?
I guess it's Gmail/Gmail IMAP version of "service of iPhone Notes which automatically sync's with IMAP folder named Notes", which is described in Web pages like next.
> http://googlesystem.blogspot.com/2010/06/save-iphone-notes-to-gmail-account.html
> http://lifehacker.com/5569758/seamlessly-sync-iphone-notes-to-a-gmail-account
> http://www.google.com/support/forum/p/gmail/thread?tid=0610650f9bcb357f&hl=en

If my guess is correct, it's independent and/or diferent from Gmail's "Notes", even if similar concept/technology/mechanism to Gmail's Notes is used by Apple for iPhone Notes.
If my guess is correct, your request is same as bug 713843.
Closing as dup of that ug.
If duping is wrong, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713843
See Also: bug 713843
No longer depends on: 713843
You need to log in before you can comment on or make changes to this bug.