[brand-Q4] update non-profit awareness snippets with stronger brand messaging

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: lforrest, Assigned: matej)

Tracking

Details

(Reporter)

Description

7 years ago
To be done after EC1 copy is finalized.

Here are the current copy variations: 
Non-profit, for the good of the Web. Find out how Firefox helps you control your online experiences. 

Firefox answers to no one but you. Learn more about our non-profit mission.

Mozilla is on a mission to keep you in control of your Web. Learn all about it.

Firefox is made to keep you in control of your Web and make it a better place. Learn more. 

These will link to the Mission page. 

Graphics:
Hearts http://cl.ly/05381S3w1a0J0R2l1H3D Rainbow http://cl.ly/1W2h452t1L2i3d202E2I
(Reporter)

Updated

7 years ago
Blocks: 695478
(Assignee)

Comment 1

7 years ago
Here are a bunch of new options based on the EC1 work:


More customization, more privacy, more control — Firefox wants to keep the power of the Web in your hands. Learn more.

Firefox is proudly non-profit and free to innovate on your behalf without compromise. Learn more about our mission.

Fast, flexible and secure, Firefox is the only browser that puts you first. Learn more about what makes us different by design.

Firefox is focused on a better experience for you and a brighter future for the Web. Find out how we put users first.

Firefox innovates only for you — all 450 million of you. Learn more about our non-profit mission.

Firefox isn't just designed to be different, it's different by design. Find out how we make browsing better for you.

We're not just building a better browser, we're building a browser for the greater good. Learn more.

Thanks for using Firefox, the proudly non-profit browser that puts you first. Together we're building a brighter future for the Web.

Comment 2

7 years ago
I like: 

Firefox is proudly non-profit and free to innovate on your behalf without compromise. Learn more about our mission.'

I like this because it brings in the non-profit message which is a message we are trying to generate more awareness around. 

Fast, flexible and secure, Firefox is the only browser that puts you first. Learn more about what makes us different by design.

I like this as well because it hits on our core points. 


Firefox isn't just designed to be different, it's different by design. Find out how we make browsing better for you.

Something about the way this one flows that i like.
(Reporter)

Comment 3

7 years ago
I like those first two from above, the third is a bit too tongue tying for a snippet. Those are: 

Firefox is proudly non-profit and free to innovate on your behalf without compromise. Learn more about our mission.

Fast, flexible and secure, Firefox is the only browser that puts you first. Learn more about what makes us different by design.

Thanks Matej!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.