Mid-air collision page confusing, users think comments will be lost

RESOLVED FIXED in Bugzilla 2.12

Status

()

Bugzilla
Bugzilla-General
RESOLVED FIXED
18 years ago
6 years ago

People

(Reporter: brendan, Assigned: Chris Yeh)

Tracking

unspecified
Bugzilla 2.12

Details

(Reporter)

Description

18 years ago
In any event, the warning is unclear to many, many people (paraphrasing: "this
will cause all changes to be lost, except for changes to the long description"
-- what's the "long description"?).

But if bugzilla can figure out that only comments are colliding, there is no
data loss, and no need for user intervention.  The comments should be added, in
whatever order makes sense (server post reception time order, probably).

This is an easy change, I hope; it shouldn't wait for a 3.0 rewrite.  People
right now are wasting time going Back and copying and pasting their comments
(which is fraught with peril, given C&P bugs; in fact, Mozilla doesn't alway
restore saved textarea data, making for even more unnecessary real data loss,
all to avoid bogus data non-loss that bugzilla makes users fret about).

/be

Updated

18 years ago
Whiteboard: 2.16


*** This bug has been marked as a duplicate of 31117 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
Permit me to morph this bug to a short-term-fixable problem I cited in the first
paragraph of my initial comment:

In any event, the warning is unclear to many, many people (paraphrasing: "this
will cause all changes to be lost, except for changes to the long description"
-- what's the "long description"?).

Can we please have a clearer warning, so jst (for instance) doesn't think he'll
blow away any other comment by submitting his anyway (when he's interacting with
the mid-air collision page)?

/be
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Mid-air collision unnecessary if comments only are colliding → Mid-air collision page confusing, users think comments will be lost
How's this sound?

Was: "This will cause all of the above changes to be overwritten, except for the 
changes to the description"

Proposed: "This will cause all of the above changes to be overwritten, except for 
the additional comments."
Assignee: tara → dave
Status: REOPENED → NEW
I think this has been proposed before (somewhere), and was knocked back by
Terry.  The logic is comments might be repeated, so it's useful to be able to
read the previous comment.

In this case I'm inclined to agree.  I'm not sure why you'd ever have to press
back in this case, but I agree that in general midair collisions should be
possible to resolve without ever pressing back.  I think mpt mentioned doing
something about this on a bug somewhere.
Hmm, I should read through reports more thoroughly.
(Reporter)

Comment 6

18 years ago
Dave: that sounds better.  Even better would be to invert the comma-separated
clauses, or somehow give primacy to the exception.

/be
QA Contact: matty

Comment 7

18 years ago
Nominating for 2.12 since this is only a small change in wording.
Whiteboard: 2.16 → 2.12
QA Contact: matty
OK, how about "Choosing this will preserve the above person's additional 
comments, but will overwite any other changes they made with yours."

Updated

18 years ago
QA Contact: matty

Comment 9

18 years ago
nuking matty to test something.

Comment 10

18 years ago
setting qa contact form element sets qa contact in the db to 0 (not to the
userid of the bogus user with blank login id.)
QA Contact: matty
(Reporter)

Comment 11

18 years ago
Sorry I didn't hack up a better sentence, myself -- now I'm gonna give a thumbs
up to Dave's revision, with a little nit-picking:

"Choosing this will preserve the above person's additional comments, but will
overwrite any other changes they made with yours."

Change "they" to "he or she", or perhaps "the above person".

Or (getting inspired) how about this:

"Clicking this button will preserve the colliding Additional 
Comments, but will overwite any other changes not also made by you."

?

Note capitalization -- maybe Additional Comments should also be italicized to
match how it appears in show_bug.cgi's output.

/be
moving to real milestones...
Whiteboard: 2.12
Target Milestone: --- → Bugzilla 2.12
(Assignee)

Comment 13

18 years ago
Dave Miller's version:

"Choosing this will preserve the above person's additional 
comments, but will overwite any other changes they made with yours."

Is probably the closest thing to what happens without starting to get into a 
very long description about individual Bugzilla fields.

I vote for the above.
(Reporter)

Comment 14

18 years ago
English nits: "this" is a vague pronoun, which is why I fumbled for "this
button" (with "Clicking" rather than "Choosing" -- not sure what's best), and
"they" is plural while "above person" is singular.  Here's another try that
avoids those problems:

"Clicking this button will preserve the above person's additional comments, but
will overwite any other changes made by that user with yours."

/be
Let's go with that. This isn't worth arguing over.

Gerv
(Reporter)

Comment 16

18 years ago
endico found the "with yours" at the end of Dave's proposal and my counters to
be clunky and unnecessary, so if you want to lop those two words off the end,
we'll thank you.

/be
(Assignee)

Comment 17

18 years ago
taking ownership
Assignee: dave → cyeh
(Assignee)

Comment 18

18 years ago
checked in fix. instead of "that user" or 'above user' which are truly hideous 
constructs, why not just put the name of that user in the sentence?

Clicking this button will preserve cyeh@bluemartini.com's additional comments, 
but will overwite any other changes made by cyeh@bluemartini.com.

Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Here i go, diving into the nitpickfest. Don't want the rest of you to
have all the fun.



Clicking this button will preserve the comments made by 
cyeh@bluemartini.com, but will overwite any other changes made at that time.

Reopening. landfill currently says:

"ou have the following choices: 
[Submit my changes anyway] This will cause all of the above changes to be 
overwritten, except for the changes to the description."

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

18 years ago
please re-verify on landfill
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
He's right, your patch is missing.  It still has the old text.
(Assignee)

Comment 23

18 years ago
try again
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.