pop3 with STARTTLS drops secure connection, cannot receive email until restart

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: mayhemer, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Earlybird 9.0a2 (2011-10-26).

I have setup 3 accounts, one of them is checked every 1 minute using pop3 and STARTTLS (pop3.volny.cz, a czech free mail) and I download only a copy, there is currently a lot of emails left on the server.  

Today (with a version one before the reported) I encoutered that I cannot received new messages from that account in particular, other ones seemed to work correctly.

After it has happened the first time, I closed EB, setup logging for mime:5,smtp:5,pop3:5 (unfortunately I didn't add timestamp) and restarted.  Update occurred, EB started and mail receiving started to work again.  But after few minutes the problem appeared again.

I will attach logs, according what I can see it seems that we fail to negotiate the ssl connection from some reason.
(Reporter)

Comment 4

7 years ago
This could potentially be caused by the mail provider - volny.cz.  The setting to check every minute might be something they started to ban recently.  I will investigate further and let you know soon.
(Reporter)

Comment 5

7 years ago
For reference: the bug started to appear on Nov 7 at around 16:30 CET.

When I manually check for emails, then quickly restart, email receive works from that account again, but just ones.  Other attempts (automatic 2 mins or manual) don't work.  So it doesn't look like a server ban unless it would be based on some session id (not sure pop protocol supports something like that).
(Reporter)

Comment 6

7 years ago
Another note: just started to work...  My theory is that this was a ssl session issue on the pop3 server.

I will monitor this and probably close as invalid.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Component: General → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.pop
(Reporter)

Comment 7

7 years ago
I have just confirmed that this was problem on the server side, they were trying some new configurations for pop3/ssl and it was fixed soon after midnight.

Closing as INVALID.

Sorry for spam.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.