Closed Bug 700458 Opened 10 years ago Closed 10 years ago

crash [@ memcpy | libGLESv2_tegra.so@0x26f8e ]

Categories

(Core :: Graphics, defect)

Other Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 697990

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: crash, Whiteboard: [mobile-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-08f32d35-d6cb-46bc-aff1-28cca2111103 .
============================================================= 

Frame 	Module 	Signature [Expand] 	Source
0 	libc.so 	memcpy 	
1 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x26f8e 	
2 		@0x632ffffe 	
3 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x25aa2 	
4 	ashmem (deleted) 	ashmem @0x5008e4 	
5 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x26e72 	
6 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x25b4e 	
7 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x2a0a2 	
8 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x2a22e 	
9 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x10bae 	
10 	ashmem (deleted) 	ashmem @0x5008e4 	
11 	libGLESv2_tegra.so 	libGLESv2_tegra.so@0x12ca6 	
12 	libxul.so 	libxul.so@0x9bad17 	
13 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:429
14 		@0xffff010f 	
15 		@0x632ffffe 	
16 	libGLESv2.so 	glTexParameteriv 	
17 	ashmem (deleted) 	ashmem @0x5008e4 	
18 	libxul.so 	mozilla::gl::GLContext::TexSubImage2D 	gfx/thebes/GLContext.h:2075
19 	libxul.so 	mozilla::gl::GLContext::UploadSurfaceToTexture 	gfx/thebes/GLContext.cpp:2010
20 	libxul.so 	mozilla::gl::TextureImageEGL::DirectUpdate 	gfx/thebes/GLContextProviderEGL.cpp:1418
21 	libxul.so 	mozilla::gl::TiledTextureImage::DirectUpdate 	gfx/thebes/GLContext.cpp:814
22 	libxul.so 	mozilla::layers::ShadowBufferOGL::Upload 	gfx/layers/opengl/ThebesLayerOGL.cpp:881
23 	libxul.so 	mozilla::layers::ShadowThebesLayerOGL::Swap 	gfx/layers/opengl/ThebesLayerOGL.cpp:910
24 	libxul.so 	mozilla::layers::ShadowLayersParent::RecvUpdate 	gfx/layers/ipc/ShadowLayersParent.cpp:326
25 	libxul.so 	mozilla::layers::PLayersParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PLayersParent.cpp:220
26 	libxul.so 	mozilla::dom::PContentParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PContentParent.cpp:1464
27 	libxul.so 	mozilla::ipc::SyncChannel::OnDispatchMessage 	ipc/glue/SyncChannel.cpp:172
28 	libxul.so 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:431
29 	libxul.so 	RunnableMethod<mozilla::ipc::RPCChannel, bool , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
30 	libxul.so 	mozilla::ipc::RPCChannel::DequeueTask::Run 	RPCChannel.h:464
31 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
32 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
33 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
34 	libxul.so 	mozilla::ipc::DoWorkRunnable::Run 	ipc/glue/MessagePump.cpp:70
35 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
36 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
37 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
38 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
39 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
40 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
41 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
42 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
43 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
44 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:232
45 	libdvm.so 	dvmPlatformInvoke 	
46 	libdvm.so 	dvmCallJNIMethod_general 	
47 	libdvm.so 	dvmResolveNativeMethod 	
48 	libdvm.so 	dvmAsmSisterStart 	
49 	libdvm.so 	dvmMterpStd 	
50 	libdvm.so 	dvmInterpret 	
51 	libdvm.so 	dvmCallMethodV 	
52 	libdvm.so 	dvmCallMethod 	
53 	libdvm.so 	dvmAttachCurrentThread 	
54 	libc.so 	__thread_entry 	
55 	libc.so 	pthread_create 	
56 		@0x5ba361ae
This looks very much like the GL_UNPACK_ROW_LENGTH-related Tegra crash for which a workaround is added in Bug 697990. Please reopen if this crash continues to occur after Bug 697990 lands.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697990
You need to log in before you can comment on or make changes to this bug.