Last Comment Bug 700591 - test_history_expiration.js has a daylight saving time timebomb
: test_history_expiration.js has a daylight saving time timebomb
Status: RESOLVED FIXED
[qa-]
: intermittent-failure
Product: Toolkit
Classification: Components
Component: Download Manager (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Marco Bonardo [::mak] (Away 6-20 Aug)
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-11-08 00:51 PST by Phil Ringnalda (:philor, back in August)
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch v1.0 (1.86 KB, patch)
2011-11-08 02:21 PST, Marco Bonardo [::mak] (Away 6-20 Aug)
dietrich: review+
christian: approval‑mozilla‑aurora+
christian: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2011-11-08 00:51:35 PST
Looks like it's during the hour from 23:00 to 24:00, starting last night, and I'd guess continuing for a week, until

let expirableTime = Date.now() - 8 * 24 * 60 * 60 * 1000;

goes back to making a time that's more than 7 days in the past even allowing for the daylight saving time change.

I pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/a62abefaab90 to mozilla-inbound, a few minutes too late to catch this instance so it won't get a chance to take effect until tomorrow night, but I see by https://tbpl.mozilla.org/php/getParsedLog.php?id=7274961&tree=Mozilla-Aurora and friends that it's already on Aurora, and so will be on Beta tomorrow, so even if that's the right thing to do we'll need a bug and flags to land it there.
Comment 1 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-08 02:12:13 PST
Thank you, yes subtracting 8 days is not enough due to the fact expiration uses
strftime('%s','now','localtime','start of day','-7 days','utc')
that also subtracts today

expiration tests do different and that's saving them, not sure why I didn't fix that test the same way :(
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/tests/expiration/head_expiration.js#138
Comment 2 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-08 02:21:13 PST
Created attachment 572761 [details] [diff] [review]
patch v1.0
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-08 02:30:45 PST
Comment on attachment 572761 [details] [diff] [review]
patch v1.0

Supposing this will land after the Aurora uplift, this should be fixed in Aurora and Beta too.

tests-only.
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-08 09:26:31 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/7810a6b2d52b
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-09 05:25:00 PST
https://hg.mozilla.org/mozilla-central/rev/7810a6b2d52b
Comment 6 christian 2011-11-15 13:38:05 PST
Comment on attachment 572761 [details] [diff] [review]
patch v1.0

[triage comment]
Approved for beta and aurora. Please land as soon as possible.
Comment 7 christian 2011-11-15 17:21:20 PST
I landed this on aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/7f1b098d8fc8

But it din't apply cleanly to beta. Please land on beta.
Comment 8 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-16 09:30:24 PST
yeah for beta the 9 should be changed to a 8, since Aurora had a workaround philor pushed temporily in central the day before the merge.
Will do that.
Comment 9 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-16 17:20:00 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/e31e3efd7e7d

Note You need to log in before you can comment on or make changes to this bug.