TrySyntax should have a rebuild count parameter

RESOLVED DUPLICATE of bug 1163698

Status

Release Engineering
General
P5
enhancement
RESOLVED DUPLICATE of bug 1163698
7 years ago
a year ago

People

(Reporter: cedricv, Unassigned)

Tracking

({trychooser})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver])

(Reporter)

Description

7 years ago
It would be very useful to test/debug intermittents if we could define a number of rebuilds to perform via the Try Syntax.

eg.
try: -b d -p win32 -u all -t none -c 10

Would build win32 debug and run the testsuite 10 times in sequence.

Updated

7 years ago
Priority: -- → P5
Whiteboard: [try-server] → [tryserver]

Updated

5 years ago
Keywords: trychooser
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
Component: Other → Tools
Duplicate of this bug: 1011640
This won't make it into the try syntax, however, we can modify mozci to help do that.
We could add this to mach and run it from the tree. Similar to this:
http://mozilla-ci-tools.readthedocs.org/en/master/use_cases.html#case-scenario-8-developer-needs-to-add-missing-platforms-jobs-for-a-try-push
This was implemented as a part of the service in bug 1163698 under the --rebuild option. It supports up to 20 rebuilds.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Contact: hwine
Resolution: --- → DUPLICATE
Duplicate of bug: 1163698
(Assignee)

Updated

a year ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.