High heap-unclassified when using IRC Cloud (possible memory leak)

RESOLVED DUPLICATE of bug 700645

Status

()

Core
XPCOM
--
major
RESOLVED DUPLICATE of bug 700645
6 years ago
4 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Asa is seeing very high heap-unclassified numbers when using IRC Cloud for a few days:

> I've found the culprit on my crazy unclassified heap numbers (like below) 
>
> 1,882.61 MB (100.0%) -- explicit
> ├──1,681.80 MB (89.33%) -- heap-unclassified
>
> It happens when I've been using IRC Cloud for a day or two. I discovered 
> today that when it gets bad, if I reload my IRC Cloud tab, the numbers
> return to something very normal immediately. I've just tested a second
> time and both times the reloading of IRC Cloud got the heap unclassified
> down to about 17% and the total memory back to very normal as well.
>
> Is this some kind of leak from that web app? Can I help figure out why 
> it's leaking into "unclassified" rather than something more normal? Is
> that even useful?

He is also experiencing very long cycle collector times.  It probably is not actually a cycle collector problem per se, but I'm leaving it in XPCOM until we come up with some place better.

Here's some more information from his initial post:

+++ This bug was initially created as a clone of Bug #696761 +++

Yesterday, on the latest nightly build, I found Firefox was pausing for more than a second every 10 or 15 seconds and it was interrupting my typing in the Web app http://irccloud.com  Smaug suggested I check my CC times and those were up well north of a second. He further suggested I might be swapping to cause those otherwise short times to be so long. Firefox was using an unusually large amount of RAM (over 2GB on my 4GB system) I restarted Firefox and everything seemed fine. 

This morning I woke up to a nearly paralyzed Firefox that was again over 2GB of RAM and barely responsive. After a re-start, things seemed better. 

The three pages I had open for the half a day or so it took to make Firefox start hanging/pausing are the MoCo Zimbra calendar, Twitter, and irccloud.com (each as pinned app tabs.)  I suspect one of these is causing us to leak or otherwise over-use RAM which gets me into a state of swapping and causing the CC pauses to be highly interruptive and for the browser to get really painfully slow.

cc'ing smaug and njn who were helpful last night. 

Testing with latest nightly build on Win7. I've been away from Firefox for 5 weeks so I don't know when this started, but it's definitely some kind of regression.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 700645
You need to log in before you can comment on or make changes to this bug.