Last Comment Bug 700654 - [layers] Different tabs don't have different visible areas
: [layers] Different tabs don't have different visible areas
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P1 normal (vote)
: ---
Assigned To: Chris Lord [:cwiiis]
:
Mentors:
: 702950 (view as bug list)
Depends on: native_droid_panning
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 06:41 PST by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-01-09 11:16 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
(1/2) Some code cleanup (4.45 KB, patch)
2011-11-08 08:02 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
(2/2) Per-tab page size and visible area (9.23 KB, patch)
2011-11-08 08:03 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
Per-tab page size and visible area (v2) (13.61 KB, patch)
2011-11-08 14:11 PST, Kartikaya Gupta (email:kats@mozilla.com)
pwalton: review+
Details | Diff | Splinter Review
Per-tab page size and visible area (v3) (15.33 KB, patch)
2011-11-11 14:14 PST, Kartikaya Gupta (email:kats@mozilla.com)
bugmail: review+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2011-11-08 06:41:46 PST
Open two tabs, zoom/pan in one of them. Then switch tabs, and note how the other one has also been zoom/panned. This should not be happening.
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-08 08:02:26 PST
Created attachment 572814 [details] [diff] [review]
(1/2) Some code cleanup
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-08 08:03:43 PST
Created attachment 572815 [details] [diff] [review]
(2/2) Per-tab page size and visible area

Both of these patches are based on the code that landed on birch (48e52668c10a) and will need to be rebased on top of the newest patch queue before landing. I can take care of that if the patches are fundamentally ok.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-08 14:07:33 PST
Comment on attachment 572814 [details] [diff] [review]
(1/2) Some code cleanup

Obsoleting this patch as I moved it into the birch-pan-zoom patch queue instead
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-08 14:11:31 PST
Created attachment 572999 [details] [diff] [review]
Per-tab page size and visible area (v2)

Update patch to also hook into handleAddTab, since that can also select a new tab and needs to kick the layer client.
Comment 5 Patrick Walton (:pcwalton) 2011-11-08 16:31:57 PST
Comment on attachment 572999 [details] [diff] [review]
Per-tab page size and visible area (v2)

Review of attachment 572999 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with name changes.

::: embedding/android/Tab.java
@@ +76,5 @@
>      private boolean mBookmark;
>      private HashMap<String, DoorHanger> mDoorHangers;
>  
> +    private IntSize mPageSize;
> +    private IntRect mVisibleArea;

mVisibleRect maybe? I've tended to use that name.

@@ +322,5 @@
> +    IntSize getPageSize() {
> +        return mPageSize;
> +    }
> +
> +    IntRect getVisibleArea() {

I'd call this "getVisibleRect".

::: embedding/android/gfx/PlaceholderLayerClient.java
@@ -100,1 +103,5 @@
> >      public void setPageSize(IntSize pageSize) { mPageSize = pageSize; }
> > +
> > +    public void tabChanged(IntSize pageSize, IntRect visibleArea) {
> > +        // can never happen because gecko is required to change tabs, and
> > +        // the GeckoSoftwareLayerClient replaces this when gecko comes up

Maybe throw then?
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-11 14:14:31 PST
Created attachment 573914 [details] [diff] [review]
Per-tab page size and visible area (v3)

Un-bitrotted such that it applies on top of a bunch of patches in the birch-pan-zoom queue (http://hg.mozilla.org/users/pwalton_mozilla.com/birch-pan-zoom/file/1deab2cd4eaf)
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-15 10:09:33 PST
This patch has been rolled into Chris' correct-displayport patch in the patch queue.
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 11:16:10 PST
*** Bug 702950 has been marked as a duplicate of this bug. ***
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-23 12:58:00 PST
This should be fixed as of https://hg.mozilla.org/projects/birch/rev/3f0f2ffed076
Comment 10 Camelia Urian 2011-11-28 04:03:53 PST
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111127 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire Z
OS: Android 2.3

Zoom/Pann is not applied to all opened tabs, only to the tab were you zoomed/panned.

Note You need to log in before you can comment on or make changes to this bug.