[java] Fennec crash on Honeycomb java.lang.IllegalArgumentException: Empty values at android.database.sqlite.SQLiteDatabase.updateWithOnConflict(SQLiteDatabase.java:1797)

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

({crash, reproducible})

unspecified
All
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox13 verified)

Details

(Whiteboard: [native-crash])

Attachments

(1 attachment)

Load a page whose favicon isn't already in the bookmarks DB. Results in this crash, presumably because the system bookmarks/history database schema changed between gingerbread and honeycomb.

E/DatabaseUtils(31693): Writing exception to parcel
E/DatabaseUtils(31693): java.lang.IllegalArgumentException: Empty values
E/DatabaseUtils(31693): 	at android.database.sqlite.SQLiteDatabase.updateWithOnConflict(SQLiteDatabase.java:1797)
E/DatabaseUtils(31693): 	at android.database.sqlite.SQLiteDatabase.update(SQLiteDatabase.java:1780)
E/DatabaseUtils(31693): 	at com.android.browser.provider.BrowserProvider2.updateHistoryInTransaction(BrowserProvider2.java:1642)
E/DatabaseUtils(31693): 	at com.android.browser.provider.BrowserProvider2.updateInTransaction(BrowserProvider2.java:1437)
E/DatabaseUtils(31693): 	at com.android.browser.provider.SQLiteContentProvider.update(SQLiteContentProvider.java:157)
E/DatabaseUtils(31693): 	at android.content.ContentProvider$Transport.update(ContentProvider.java:233)
E/DatabaseUtils(31693): 	at android.content.ContentProviderNative.onTransact(ContentProviderNative.java:208)
E/DatabaseUtils(31693): 	at android.os.Binder.execTransact(Binder.java:320)
E/DatabaseUtils(31693): 	at dalvik.system.NativeStart.run(Native Method)
I/Gecko   (32670): AndroidBridge::NotifyIMEChange
I/Gecko   (32670): AndroidBridge::NotifyIMEChange
I/Gecko   (32670): AndroidBridge::NotifyIME
I/Gecko   (32670): AndroidBridge::NotifyIMEEnabled
I/Gecko   (32670): AndroidBridge::GetDPI
D/dalvikvm(31693): GC_CONCURRENT freed 413K, 8% free 6563K/7111K, paused 2ms+2ms
D/WindowManager(  286): Desired input method target: Window{416dc008 org.mozilla.fennec_kats/org.mozilla.fennec_kats.App paused=false}
D/WindowManager(  286): Current focus: Window{416dc008 org.mozilla.fennec_kats/org.mozilla.fennec_kats.App paused=false}
D/WindowManager(  286): Last focus: Window{416dc008 org.mozilla.fennec_kats/org.mozilla.fennec_kats.App paused=false}
D/WindowManager(  286): IM target client: com.android.internal.view.IInputMethodClient$Stub$Proxy@41d912e8
D/WindowManager(  286): IM target client binder: android.os.BinderProxy@409b04e0
D/WindowManager(  286): Requesting client binder: android.os.BinderProxy@409b04e0
W/dalvikvm(32670): threadid=16: thread exiting with uncaught exception (group=0x40177760)
D/InputManagerService(  286): startInputLocked: cs=ClientState{417b26c8 uid 10103 pid 32670}, cs.pid=32670, Binding.getCallingPid()=286
I/WindowManager(  286): Putting input method here!
D/WindowManager(  286):     w.mAttrs.token=ActivityRecord{407cd4f8 org.mozilla.fennec_kats/.App}
D/WindowManager(  286):     w.mToken=AppWindowToken{4261c9b8 token=ActivityRecord{407cd4f8 org.mozilla.fennec_kats/.App}}
D/WindowManager(  286):     token=AppWindowToken{4261c9b8 token=ActivityRecord{407cd4f8 org.mozilla.fennec_kats/.App}}
I/WindowManager(  286): Placing input method @4
E/AndroidRuntime(32670): FATAL EXCEPTION: AsyncTask #5
E/AndroidRuntime(32670): java.lang.RuntimeException: An error occured while executing doInBackground()
E/AndroidRuntime(32670): 	at android.os.AsyncTask$3.done(AsyncTask.java:266)
E/AndroidRuntime(32670): 	at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
E/AndroidRuntime(32670): 	at java.util.concurrent.FutureTask.setException(FutureTask.java:124)
E/AndroidRuntime(32670): 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
E/AndroidRuntime(32670): 	at java.util.concurrent.FutureTask.run(FutureTask.java:137)
E/AndroidRuntime(32670): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1081)
E/AndroidRuntime(32670): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:574)
E/AndroidRuntime(32670): 	at java.lang.Thread.run(Thread.java:1020)
E/AndroidRuntime(32670): Caused by: java.lang.IllegalArgumentException: Empty values
E/AndroidRuntime(32670): 	at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:166)
E/AndroidRuntime(32670): 	at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:136)
E/AndroidRuntime(32670): 	at android.content.ContentProviderProxy.update(ContentProviderNative.java:534)
E/AndroidRuntime(32670): 	at android.content.ContentResolver.update(ContentResolver.java:847)
E/AndroidRuntime(32670): 	at org.mozilla.gecko.Favicons$LoadFaviconTask.saveFaviconToDb(Favicons.java:226)
E/AndroidRuntime(32670): 	at org.mozilla.gecko.Favicons$LoadFaviconTask.downloadFavicon(Favicons.java:252)
E/AndroidRuntime(32670): 	at org.mozilla.gecko.Favicons$LoadFaviconTask.doInBackground(Favicons.java:299)
E/AndroidRuntime(32670): 	at org.mozilla.gecko.Favicons$LoadFaviconTask.doInBackground(Favicons.java:171)
E/AndroidRuntime(32670): 	at android.os.AsyncTask$2.call(AsyncTask.java:252)
E/AndroidRuntime(32670): 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
E/AndroidRuntime(32670): 	... 4 more
W/ActivityManager(  286):   Force finishing activity org.mozilla.fennec_kats/.App
Keywords: crash
Summary: Fennec crash on Honeycomb → [java] Fennec crash on Honeycomb java.lang.IllegalArgumentException: Empty values at android.database.sqlite.SQLiteDatabase.updateWithOnConflict(SQLiteDatabase.java:1797)
Whiteboard: [mobile-crash]
Whiteboard: [mobile-crash] → [native-crash]

Updated

7 years ago
Severity: normal → critical
Keywords: reproducible
Duplicate of this bug: 700995
Created attachment 573180 [details] [diff] [review]
Patch to fix crash
Assignee: nobody → kgupta
Status: NEW → ASSIGNED
Attachment #573180 - Flags: review?(lucasr.at.mozilla)
Duplicate of this bug: 700842
Comment on attachment 573180 [details] [diff] [review]
Patch to fix crash

Review of attachment 573180 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Just change commit summary to "Bug 700720 - Fix crash in Favicons.java on Honeycomb" to be a little more specific.
Attachment #573180 - Flags: review?(lucasr.at.mozilla) → review+
Fixed, committed.

http://hg.mozilla.org/projects/birch/rev/8515bd5b8993
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 6

7 years ago
Sorry, does this mean it won't crash any more?
Assuming the crash you were seeing was this one, yeah, it shouldn't crash any more with the fix applied.

Comment 8

7 years ago
Many thanks for answering me so soon!
Will I see the fix in today's birch build? If so, what if I still get crashes? Should I file again? If not, when should I expect to see the fix?
(In reply to Gabriela from comment #8)
> Many thanks for answering me so soon!
> Will I see the fix in today's birch build? If so, what if I still get
> crashes? Should I file again? If not, when should I expect to see the fix?

You will see it in tomorrow's birch build, unless you build your self or install the tinderbox build with this fix in it.

If the crash is exactly the same as this crash, you could reopen. Otherwise, file a new bug.
I've also put an APK at https://people.mozilla.com/~kgupta/tmp/fennec-bmupdatefix.apk with the fix if you don't want to wait for tomorrow's birch build (you'll need to have and Android SDK installed to load the APK).
Right, thanks

I'm afraid I don't know enough to know if any future crashes would be exactly the same as this one. I just filed because yesterday's birch build crashed every few minutes and I tried several ways to avoid crashing but nothing worked.
These patches were backed while investigating Talos failures.  Now that tests are green again, we will need to reland.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
backout was backed out https://hg.mozilla.org/projects/birch/rev/6f925b45a547
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Verified fixed on:

Firefox 13.0a1 (2012-02-17)
20120217031227
http://hg.mozilla.org/mozilla-central/rev/2271cb92cc05

--
Device: Motorola Droid PRO
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
status-firefox13: --- → verified
You need to log in before you can comment on or make changes to this bug.