Last Comment Bug 700734 - Unnecessary "not derived from nsISupports" warnings for XPCOM pseudo-enums
: Unnecessary "not derived from nsISupports" warnings for XPCOM pseudo-enums
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla12
Assigned To: :Irving Reid (No longer working on Firefox)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 11:14 PST by :Irving Reid (No longer working on Firefox)
Modified: 2012-01-09 15:07 PST (History)
1 user (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove 'not derived from nsISupports' warning (1.56 KB, patch)
2011-11-08 11:18 PST, :Irving Reid (No longer working on Firefox)
khuey: review+
Details | Diff | Review

Description :Irving Reid (No longer working on Firefox) 2011-11-08 11:14:14 PST
Thunderbird has many IDL definitions of pseudo-enums, basically an IDL interface that only declares a bunch of constants. Because we never create an instance of the IDL object, it doesn't need any of the normal nsISupports infrastructure.

xpcom prints warnings about all of these, like:

warning: interface 'nsMsgPriority' not derived from nsISupports, /Users/ireid/tbird/comm-central/mailnews/base/public/MailNewsTypes2.idl line 52:0
interface nsMsgPriority {
^

Based on a conversation on irc #developers, this warning doesn't add much value and can be removed.
Comment 1 :Irving Reid (No longer working on Firefox) 2011-11-08 11:18:42 PST
Created attachment 572912 [details] [diff] [review]
Remove 'not derived from nsISupports' warning
Comment 2 :Irving Reid (No longer working on Firefox) 2012-01-06 13:50:37 PST
I don't have mozilla-central checkin privileges; anyone ready to take this on?
Comment 4 Ed Morley [:emorley] 2012-01-09 15:07:52 PST
https://hg.mozilla.org/mozilla-central/rev/8e7225a8b1cc

Note You need to log in before you can comment on or make changes to this bug.