Last Comment Bug 700754 - Add Profiler responsiveness hooks
: Add Profiler responsiveness hooks
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Benoit Girard (:BenWa)
:
Mentors:
Depends on: 606574 699918
Blocks: 653703 683229
  Show dependency treegraph
 
Reported: 2011-11-08 11:56 PST by Benoit Girard (:BenWa)
Modified: 2011-12-04 11:50 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.79 KB, patch)
2011-11-08 11:56 PST, Benoit Girard (:BenWa)
ted: review+
Details | Diff | Review

Description Benoit Girard (:BenWa) 2011-11-08 11:56:25 PST
Created attachment 572928 [details] [diff] [review]
patch

We need to integrate with the tracer event to correlate profile data.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-11-10 12:51:59 PST
Comment on attachment 572928 [details] [diff] [review]
patch

Review of attachment 572928 [details] [diff] [review]:
-----------------------------------------------------------------

I assume you have a follow-up patch that makes these into something that's not a no-op?
Comment 2 Benoit Girard (:BenWa) 2011-11-27 15:07:31 PST
Yes, we will need changes to the profiler to store the timing information. Since we're working on the ports at the moment I don't want to add needless conflicts for a simple follow up change.

Submitted a try run, will land if it's green.
Comment 3 Mozilla RelEng Bot 2011-11-27 18:40:25 PST
Try run for f3fd9999da3e is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f3fd9999da3e
Results (out of 13 total builds):
    success: 11
    failure: 2
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/b56girard@gmail.com-f3fd9999da3e
Comment 4 Mozilla RelEng Bot 2011-11-27 21:20:21 PST
Try run for f97f664423bc is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f97f664423bc
Results (out of 13 total builds):
    success: 12
    failure: 1
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/b56girard@gmail.com-f97f664423bc
Comment 6 Marco Bonardo [::mak] 2011-11-28 05:30:44 PST
https://hg.mozilla.org/mozilla-central/rev/002d1b181fb8

Note You need to log in before you can comment on or make changes to this bug.