Nightly nsIDOMStorage.getItem failures on Twitter and Google Maps

RESOLVED INVALID

Status

()

Core
DOM
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: ddahl, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I see the same error on both google maps and twitter. This is sometimes cleared up after a restart.

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMStorage.getItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://maps.google.com/m/places?oi=nojs#ipd:mode=home :: <TOP_LEVEL> :: line 287"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMStorage.getItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: https://si0.twimg.com/b/1/bundle/phoenix-core-en-201111081004.js :: J :: line 36"  data: no]

This effectively kills much of the functionality of both sites. Google maps in particular is basically unusable.
David:

- with what version is this happening?
- do you have steps to reproduce?  (the more detailed the better)
I get the same

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMStorage.getItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: https://static-cdn.addons.mozilla.net/media/js/impala-min.js?build=a018fb5 :: <TOP_LEVEL> :: line 4"  data: no]

when loading
https://addons.mozilla.org/en-US/thunderbird/addon/lightning/
Sorry for bug spam, version is
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1

Steps to reproduce:
- Enter
https://addons.mozilla.org/en-US/thunderbird/addon/lightning/
in awesomebar and press enter

Open Error Console end see error.
Spinner animation between
"About this Add-on" box and
"Developer's comments" never stops.

Clicking on "Developer's comments" does not open the box.
(In reply to Stefan Fleiter from comment #3)
> Sorry for bug spam, version is
> Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1
> 
> Steps to reproduce:
> - Enter
> https://addons.mozilla.org/en-US/thunderbird/addon/lightning/
> in awesomebar and press enter
> 
> Open Error Console end see error.
> Spinner animation between
> "About this Add-on" box and
> "Developer's comments" never stops.
> 
> Clicking on "Developer's comments" does not open the box.

Cannot reproduce with a clean profile.  Can you try with a clean profile please?  Are you e.g. logged in to addons.mozilla.org?  What else is different on your side from standard settings?
After restart with "Help / Restart with Addons disbaled..."
and another restart to enable them again I can not reproduce this anymore.

That already happened several times when trying to reproduce problems
without addons.
Is it possible that some generated files get corrupted occasionally and get
regenerated/repaired by that action?
(Reporter)

Comment 6

6 years ago
I can also confirm this is not a problem anymore on a clean profile. I cannot imagine how any of my (few) addons are causing this, however it is no doubt the problem.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
This happened for me again, today.
Anything that could be done to find out the cause?
I have quite some addons and with this type of bug there is no simple way to find out which one is at fault.
(In reply to Stefan Fleiter from comment #7)
> This happened for me again, today.
> Anything that could be done to find out the cause?
> I have quite some addons and with this type of bug there is no simple way to
> find out which one is at fault.

Start with a clean profile (http://support.mozilla.com/en-US/kb/Managing-profiles).
Install addons one by one as you have installed them in your regular profile.
Try with each new installed addon to reproduce (good to have reliable steps to reproduce).
There is probably no simpler way of figuring this out.
@Honza:
Thanks for the suggestion.

The problem here is that deactivating one addon can make the symptoms vanish only to occur later again.

The old binary search pattern does not help in those situations one can
not reproduce the bug fast or secure enough.

Comment 10

6 years ago
This happens since Aurora 10, makes Twitter and other sites unusable because some JavaScript files cannot be loaded.

Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMStorage.getItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://www.pirateslovedaisies.com/scripts/compiled-scripts.js :: <TOP_LEVEL> :: line 424"  data: no]
Does everybody on this bug report have Better Privacy installed?
I think that's what causing the problem for me.
(Reporter)

Comment 12

6 years ago
(In reply to Stefan Fleiter from comment #11)
> Does everybody on this bug report have Better Privacy installed?
> I think that's what causing the problem for me.

I did have that installed, I turned it and other addons off and my problem went away.
(In reply to David Dahl :ddahl from comment #12)
> (In reply to Stefan Fleiter from comment #11)
> > Does everybody on this bug report have Better Privacy installed?
> > I think that's what causing the problem for me.
> 
> I did have that installed, I turned it and other addons off and my problem
> went away.

David, you turned that what?  On or off?  What exactly is helping you to fix the problem and what is the minimal config to reproduce the problem?
(Reporter)

Comment 14

6 years ago
I disabled "Better Privacy" along with other addons. Then these symptoms went away.

(In reply to Honza Bambas (:mayhemer) from comment #13)
> (In reply to David Dahl :ddahl from comment #12)
> > (In reply to Stefan Fleiter from comment #11)
> > > Does everybody on this bug report have Better Privacy installed?
> > > I think that's what causing the problem for me.
> > 
> > I did have that installed, I turned it and other addons off and my problem
> > went away.
> 
> David, you turned that what?  On or off?  What exactly is helping you to fix
> the problem and what is the minimal config to reproduce the problem?
(In reply to David Dahl :ddahl from comment #14)
> I disabled "Better Privacy" along with other addons. Then these symptoms
> went away.

And if you turn on _only_ "Better Privacy", is the problem present again?

And if you leave "Better Privacy" off and turn all other add-ons on, is the problem still gone?

Thanks for quick feedback!
(Reporter)

Comment 16

6 years ago
I have turned off all of my extensions except Better Privacy, I am seeing that error again, especially with urls like: https://twitter.com/#!/robcee/status/147088297364164608/photo/1

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMStorage.getItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: https://si0.twimg.com/b/1/bundle/phoenix-core-en-201112131036.js :: J :: line 36"  data: no]

It seems like there is eventually an exception thrown that kills the loading of one of twitter's internal JS apis, which kills most posting and other advanced functionality - anything but reading the feed.

Of course, Twitter is acting up right now as well, but I'll keep this config going for a few more hours
(Reporter)

Comment 17

6 years ago
Ok, I think it is "Better Privacy" causing the failure here. I am seeing all of the symptoms now where I cannot post or see the twitter "details" sidebar expand.
(In reply to David Dahl :ddahl from comment #17)
> Ok, I think it is "Better Privacy" causing the failure here. I am seeing all
> of the symptoms now where I cannot post or see the twitter "details" sidebar
> expand.

Thanks for investigating this, David!  I'll try the add-on my self and see what's happening.
(In reply to Honza Bambas (:mayhemer) from comment #18)
> Thanks for investigating this, David!  I'll try the add-on my self and see
> what's happening.

So already any results of testing with "Better Privacy"?

Comment 20

6 years ago
With Firefox 11 Aurora Twitter works when Better Privacy option "DOMStorage file auto-delete" is disabled.
I am enabling it again to test if the "Firefox 10+ support" of version 1.68 really works ;)
Although I couldn't really correlate the source changes between 1.67 and 1.68 to fix the nsIDOMStorage.getItem() security exception for Twitter.

The best thing would be if Twitter would use a try-block for getItem() to catch the exception in https://si0.twimg.com/b/1/bundle/phoenix-core-en-201201251013.js line 36 column 34460.
localStorage should not be so important that the whole application crashes without it, especially on reading. And you can always use a cookie fallback for example.

But then again, why is Twitter still using jQuery 1.5.2 and Modernizr 1.5?
You need to log in before you can comment on or make changes to this bug.