Last Comment Bug 700937 - Scaling of favicons should be either 1x or 2x, never inbetween
: Scaling of favicons should be either 1x or 2x, never inbetween
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: P3 normal (vote)
: ---
Assigned To: Sriram Ramasubramanian [:sriram]
:
Mentors:
Depends on: 700936
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 22:03 PST by Alex Limi (:limi) — Firefox UX Team
Modified: 2016-07-29 14:20 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Showing the blurred edges of favicon scaling (38.51 KB, image/jpeg)
2011-11-08 22:03 PST, Alex Limi (:limi) — Firefox UX Team
no flags Details

Description Alex Limi (:limi) — Firefox UX Team 2011-11-08 22:03:04 PST
Created attachment 573085 [details]
Showing the blurred edges of favicon scaling

Right now, it looks like we scale up favicons and introduce blur/antialias by scaling them to sizes that aren't 1:1 or 2:1.

If the URL bar has enough space on a given device to render the favicon at 2x size, it should do that, otherwise it should render it at 1:1 and center it instead. Scaling 16x16 icons with antialias just looks bad.

(Of course, if there's a 32x32 icon and we have the space, we should use that)

Attached is a screenshot that shows the blurring introduced.
Comment 1 Ian Barlow (:ibarlow) 2011-11-09 08:32:56 PST
Hm, the favicons should be displaying at 32x32, and upscaled crisply if there's only a 16x16 available. 

The current nightlies seem to be drawing them at 36x36, so they need to come down a bit. And we need to make sure we're using crisp scaling, rather than anti-aliased.
Comment 2 Madhava Enros [:madhava] 2011-11-14 09:48:23 PST
Can we see why we seem to be doing the 36x36? We should be 2x-ing them to 32px when necessary.
Comment 3 Sriram Ramasubramanian [:sriram] 2011-11-14 10:15:00 PST
The favicons are using 24x24 in the URL bar and tabs-tray. Since it is in "dip", they seem to be like 36X36 because of the device's dpi.
Comment 4 Sriram Ramasubramanian [:sriram] 2011-11-14 15:35:33 PST
Bug 700936 fixes the favicon in the URL bar. The rest of the favicons should be decided on a case by case basis.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-15 05:58:05 PST
fixed by bug 700936

Note You need to log in before you can comment on or make changes to this bug.