Last Comment Bug 700951 - Back button "stack" is inconsistent when selecting the URL bar
: Back button "stack" is inconsistent when selecting the URL bar
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Lucas Rocha (:lucasr)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 23:19 PST by Alex Limi (:limi) — Firefox UX Team
Modified: 2012-01-09 11:44 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
(1/2) Factor out method to cancel and finish AwesomeBar (1.10 KB, patch)
2011-11-17 06:48 PST, Lucas Rocha (:lucasr)
mark.finkle: review+
Details | Diff | Review
(2/2) Back button on AwesomeBar should return to browser (6.85 KB, patch)
2011-11-17 06:48 PST, Lucas Rocha (:lucasr)
mark.finkle: review+
Details | Diff | Review

Description Alex Limi (:limi) — Firefox UX Team 2011-11-08 23:19:46 PST
How to reproduce:

1. Look at a web page
2. Tap the URL bar, keyboard comes up and you can start typing
3. Click the hardware back button

Expected result:
4. You are returned to the web page (the tap you just did is undone)

What actually happens:
4. The keyboard disappears, which means that you have to tap the hardware back button *twice* to get back to where you were.

Recommendation: the activation of the URL bar should be treated as a single event in the stack, not as focus textfield + activate keyboard as two separate actions.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-08 23:22:17 PST
What if I just want to hide the keyboard so I can pan the long list and see more results? Using BACK to hide the keyboard, but not lose the current context is typical on Android.
Comment 2 Kevin Brosnan [:kbrosnan] 2011-11-08 23:32:17 PST
This is the behavior XUL Fennec had. As I recall the idea was that people may want to see more awesome screen results and hiding the keyboard is not unexpected. However a quick overview of Opera, Stock 2.2 and 2.3 and Dolphin HD use Limi's behavior.
Comment 3 Ian Barlow (:ibarlow) 2011-11-09 07:11:24 PST
I just filed a bug to get back our "dismiss keyboard by scrolling through awesomescreen list" that currently exists on XUL versions of mobile ffx - bug 701014

Given that, maybe we could try having the back button go all the way back to the page not matter what, and see how it feels?
Comment 4 Madhava Enros [:madhava] 2011-11-09 07:12:37 PST
People should be able to see more awesomescreen results just by starting to pan the result list (opening another bug for this).

At one point, putting the keyboard away first was standard Android behavior, but it looks like this is no longer the case. Let's do it!
Comment 5 Madhava Enros [:madhava] 2011-11-09 07:16:48 PST
One amendment - In landscape, when only a field and the keyboard are visible, the back button should just take you one level up -- i.e. to the awesomescreen. I don't think this will seem inconsistent to people.
Comment 6 Lucas Rocha (:lucasr) 2011-11-17 06:48:08 PST
Created attachment 575173 [details] [diff] [review]
(1/2) Factor out method to cancel and finish AwesomeBar
Comment 7 Lucas Rocha (:lucasr) 2011-11-17 06:48:57 PST
Created attachment 575174 [details] [diff] [review]
(2/2) Back button on AwesomeBar should return to browser
Comment 9 Camelia Urian 2011-11-24 06:44:45 PST
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111123 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire Z
OS: Android 2.3

Verified fixed

Note You need to log in before you can comment on or make changes to this bug.