Bad results when going back and forth not fully loaded pages

VERIFIED DUPLICATE of bug 68483

Status

()

Core
Networking
--
major
VERIFIED DUPLICATE of bug 68483
17 years ago
17 years ago

People

(Reporter: mats, Assigned: neeti)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
DESCRIPTION:
Bad results when going back and forth not fully loaded pages

STEPS TO REPRODUCE:
1. go to http://www.w3.org/TR/ and *before* the page is fully loaded ...
2. scroll down two pages and click "HTML 4.01 Specification"
3. go back and forth

ACTUAL RESULTS:
Alt. 1
  I see "most of http://www.w3.org/TR/" (lower part) + "a HTTP header" +
  "The full content of http://www.w3.org/TR/html401/" on the same page.

Alt. 2
  http://www.w3.org/TR/html401/ with the page background garbled.

Alt. 3
  I see large chunk of style sheet code.

DOES NOT WORK CORRECTLY ON:
Mozilla nightly build 2001-02-23-11 on Windows 98 SE.

ADDITIONAL INFO:
It seems that Alt 1 is the result if http://www.w3.org/TR/html401/ have not
previously been visited. Alt 2 is the result if the page has been visited.
Alt 3 occurs rarely.
(Reporter)

Comment 1

17 years ago
Created attachment 26138 [details]
Screenshot of Alt 1
(Reporter)

Comment 2

17 years ago
Created attachment 26139 [details]
Screenshot of Alt 2

Comment 3

17 years ago
dup of bug 68483 "server headers render as clear text in browser"

*** This bug has been marked as a duplicate of 68483 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
Sorry, didn't see that one. Marking VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.